Bug 64166 - Visibility property is not animated correctly when is accelerated compositing is enabled
Summary: Visibility property is not animated correctly when is accelerated compositing...
Status: RESOLVED DUPLICATE of bug 29984
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel Unspecified
: P2 Major
Assignee: Nobody
URL: http://wavded.github.com/humane-js/
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-08 07:42 PDT by Marc Harter
Modified: 2011-07-11 20:27 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Harter 2011-07-08 07:42:07 PDT
Visit: http://wavded.github.com/humane-js/

Click on any link to show the popup notification.

This animation works on Safari 5.0.5 on Windows... but does not work on Mac.  I've also noticed this behavior on iOS.

To make it work, you have to remove the visibility property as part of the transition.

Confused because same Safari ver on Windows works but not on Mac.  You can see it working if you try FF4+ or Chrome.

Marc
Comment 1 Alexey Proskuryakov 2011-07-11 16:05:38 PDT
Works on Mac if I disable accelerated compositing.
Comment 2 Simon Fraser (smfr) 2011-07-11 16:42:17 PDT

*** This bug has been marked as a duplicate of bug 29984 ***
Comment 3 Marc Harter 2011-07-11 20:27:28 PDT
I switched humane-js to use z-index instead of visibility so the above link should work now but the issue remains.