Bug 63529 - SVGAnimatedType should support SVGBoolean animation
Summary: SVGAnimatedType should support SVGBoolean animation
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Dirk Schulze
URL:
Keywords:
Depends on:
Blocks: 41761
  Show dependency treegraph
 
Reported: 2011-06-28 06:26 PDT by Dirk Schulze
Modified: 2011-06-28 23:59 PDT (History)
2 users (show)

See Also:


Attachments
Patch (29.04 KB, patch)
2011-06-28 06:41 PDT, Dirk Schulze
zimmermann: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk Schulze 2011-06-28 06:26:45 PDT
SVGAnimatedType should support SVGBoolean animation
Comment 1 Dirk Schulze 2011-06-28 06:41:24 PDT
Created attachment 98908 [details]
Patch
Comment 2 WebKit Review Bot 2011-06-28 06:44:11 PDT
Attachment 98908 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'LayoutTests/ChangeLog', u'LayoutTests/plat..." exit_code: 1

Source/WebCore/svg/SVGAnimatedBoolean.h:50:  The parameter type should use PassOwnPtr instead of OwnPtr.  [readability/pass_ptr] [5]
Source/WebCore/svg/SVGAnimatedBoolean.h:50:  The parameter type should use PassOwnPtr instead of OwnPtr.  [readability/pass_ptr] [5]
Source/WebCore/svg/SVGAnimatedBoolean.h:51:  The parameter type should use PassOwnPtr instead of OwnPtr.  [readability/pass_ptr] [5]
Source/WebCore/svg/SVGAnimatedBoolean.h:51:  The parameter type should use PassOwnPtr instead of OwnPtr.  [readability/pass_ptr] [5]
Source/WebCore/svg/SVGAnimatedBoolean.h:53:  The parameter type should use PassOwnPtr instead of OwnPtr.  [readability/pass_ptr] [5]
Source/WebCore/svg/SVGAnimatedBoolean.h:53:  The parameter type should use PassOwnPtr instead of OwnPtr.  [readability/pass_ptr] [5]
Source/WebCore/svg/SVGAnimatedBoolean.h:53:  The parameter type should use PassOwnPtr instead of OwnPtr.  [readability/pass_ptr] [5]
Source/WebCore/svg/SVGAnimatedBoolean.cpp:42:  The parameter type should use PassOwnPtr instead of OwnPtr.  [readability/pass_ptr] [5]
Source/WebCore/svg/SVGAnimatedBoolean.cpp:42:  The parameter type should use PassOwnPtr instead of OwnPtr.  [readability/pass_ptr] [5]
Source/WebCore/svg/SVGAnimatedBoolean.cpp:51:  The parameter type should use PassOwnPtr instead of OwnPtr.  [readability/pass_ptr] [5]
Source/WebCore/svg/SVGAnimatedBoolean.cpp:51:  The parameter type should use PassOwnPtr instead of OwnPtr.  [readability/pass_ptr] [5]
Source/WebCore/svg/SVGAnimatedBoolean.cpp:62:  The parameter type should use PassOwnPtr instead of OwnPtr.  [readability/pass_ptr] [5]
Source/WebCore/svg/SVGAnimatedBoolean.cpp:62:  The parameter type should use PassOwnPtr instead of OwnPtr.  [readability/pass_ptr] [5]
Source/WebCore/svg/SVGAnimatedBoolean.cpp:62:  The parameter type should use PassOwnPtr instead of OwnPtr.  [readability/pass_ptr] [5]
Total errors found: 14 in 20 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Nikolas Zimmermann 2011-06-28 07:03:22 PDT
Comment on attachment 98908 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=98908&action=review

r=me. Don't forget the mac-wk2/qt-wk2/etc. Skipped list update! Otherwhise ossy will complain :-)

> Source/WebCore/svg/SVGAnimatedBoolean.cpp:36
> +    DEFINE_STATIC_LOCAL(const AtomicString, trueString, ("true"));

Why AtomicString here?? Use String.
Comment 4 Dirk Schulze 2011-06-28 23:59:05 PDT
Committed r89993: <http://trac.webkit.org/changeset/89993>