RESOLVED FIXED Bug 63397
SVGAnimatedType should support SVGNumberOptionalNumber animation
https://bugs.webkit.org/show_bug.cgi?id=63397
Summary SVGAnimatedType should support SVGNumberOptionalNumber animation
Dirk Schulze
Reported 2011-06-26 02:46:49 PDT
SVGAnimatedType should support SVGNumberOptionalNumber animation.
Attachments
Patch (46.39 KB, patch)
2011-06-26 03:04 PDT, Dirk Schulze
zimmermann: review+
Dirk Schulze
Comment 1 2011-06-26 03:04:07 PDT
WebKit Review Bot
Comment 2 2011-06-26 03:06:24 PDT
Attachment 98620 [details] did not pass style-queue: Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'LayoutTests/ChangeLog', u'LayoutTests/svg/..." exit_code: 1 Source/WebCore/svg/SVGAnimatedNumberOptionalNumber.h:40: The parameter type should use PassOwnPtr instead of OwnPtr. [readability/pass_ptr] [5] Source/WebCore/svg/SVGAnimatedNumberOptionalNumber.h:40: The parameter type should use PassOwnPtr instead of OwnPtr. [readability/pass_ptr] [5] Source/WebCore/svg/SVGAnimatedNumberOptionalNumber.h:41: The parameter type should use PassOwnPtr instead of OwnPtr. [readability/pass_ptr] [5] Source/WebCore/svg/SVGAnimatedNumberOptionalNumber.h:41: The parameter type should use PassOwnPtr instead of OwnPtr. [readability/pass_ptr] [5] Source/WebCore/svg/SVGAnimatedNumberOptionalNumber.h:43: The parameter type should use PassOwnPtr instead of OwnPtr. [readability/pass_ptr] [5] Source/WebCore/svg/SVGAnimatedNumberOptionalNumber.h:43: The parameter type should use PassOwnPtr instead of OwnPtr. [readability/pass_ptr] [5] Source/WebCore/svg/SVGAnimatedNumberOptionalNumber.h:43: The parameter type should use PassOwnPtr instead of OwnPtr. [readability/pass_ptr] [5] Source/WebCore/svg/SVGAnimatedNumberOptionalNumber.cpp:49: The parameter type should use PassOwnPtr instead of OwnPtr. [readability/pass_ptr] [5] Source/WebCore/svg/SVGAnimatedNumberOptionalNumber.cpp:49: The parameter type should use PassOwnPtr instead of OwnPtr. [readability/pass_ptr] [5] Source/WebCore/svg/SVGAnimatedNumberOptionalNumber.cpp:60: The parameter type should use PassOwnPtr instead of OwnPtr. [readability/pass_ptr] [5] Source/WebCore/svg/SVGAnimatedNumberOptionalNumber.cpp:60: The parameter type should use PassOwnPtr instead of OwnPtr. [readability/pass_ptr] [5] Source/WebCore/svg/SVGAnimatedNumberOptionalNumber.cpp:78: The parameter type should use PassOwnPtr instead of OwnPtr. [readability/pass_ptr] [5] Source/WebCore/svg/SVGAnimatedNumberOptionalNumber.cpp:78: The parameter type should use PassOwnPtr instead of OwnPtr. [readability/pass_ptr] [5] Source/WebCore/svg/SVGAnimatedNumberOptionalNumber.cpp:78: The parameter type should use PassOwnPtr instead of OwnPtr. [readability/pass_ptr] [5] Total errors found: 14 in 27 files If any of these errors are false positives, please file a bug against check-webkit-style.
Nikolas Zimmermann
Comment 3 2011-06-26 03:44:08 PDT
Comment on attachment 98620 [details] Patch r=me!
Dirk Schulze
Comment 4 2011-06-26 04:25:04 PDT
Adam Barth
Comment 5 2011-06-26 23:15:56 PDT
This patch added using namespace std; to a header file. That seems pretty uncool. /me will fixenate.
Adam Barth
Comment 6 2011-06-26 23:39:14 PDT
Dirk Schulze
Comment 7 2011-06-26 23:42:11 PDT
(In reply to comment #6) > Fixenated in http://trac.webkit.org/changeset/89786 Oh, sorry. Thanks for fixing.
Adam Barth
Comment 8 2011-06-26 23:46:10 PDT
For the record, this caused broke the clang build. We don't have much clang coverage on webkit.org, so it's easy to break that build. Adding more coverage is on my list of things I'd like to do, but it's not at the top yet.
Note You need to log in before you can comment on or make changes to this bug.