Bug 63367 - REGRESSION (r72052): Placeholder text alignment is no longer defaulted to the alignment of regular text
Summary: REGRESSION (r72052): Placeholder text alignment is no longer defaulted to the...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P1 Normal
Assignee: Nobody
URL:
Keywords: Regression
: 67495 (view as bug list)
Depends on: 49452 64253
Blocks: 63927
  Show dependency treegraph
 
Reported: 2011-06-24 17:19 PDT by Yair Yogev
Modified: 2011-09-04 18:18 PDT (History)
12 users (show)

See Also:


Attachments
testcase with different alignments\directions (544 bytes, text/html)
2011-06-24 17:19 PDT, Yair Yogev
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yair Yogev 2011-06-24 17:19:42 PDT
Created attachment 98565 [details]
testcase with different alignments\directions

Before r72052, if a textbox had "text-align: center" style, its placeholder also appeared in the middle (same goes for "text-align: right" accordingly)

but since then, the placeholder is always aligned to the left for regular direction input elements (and to the right for dir="rtl" elements)

This is now affecting Chromium's DOM-UI options for Hebrew\Arabic UI since many input elements there were edited recently to have right alignment to properly support URLs and patterns (intentionally not using dir=ltr which isn't correct for such content).



Note: This issue is different than bug 54814 which is about the support for webkit-input-placeholder which got lost in r72052
also related but different: 
Bug 54797 REGRESSION (r72052): Placeholder text isn't centered with a large line-height

Tested using windows build
Comment 1 Yair Yogev 2011-06-24 17:28:26 PDT
small correction in the summary: intentionally not using dir=*rtl*
Comment 2 Yair Yogev 2011-06-26 08:56:42 PDT
InChromium issue: http://crbug.com/87546
Comment 3 Kent Tamura 2011-07-13 19:18:53 PDT
Fixed by http://trac.webkit.org/changeset/90971
Comment 4 Kent Tamura 2011-09-04 18:18:44 PDT
*** Bug 67495 has been marked as a duplicate of this bug. ***