Bug 63115 - fast/css/font-face-in-shadow-DOM.html is failing on Win XP Debug
Summary: fast/css/font-face-in-shadow-DOM.html is failing on Win XP Debug
Status: RESOLVED CONFIGURATION CHANGED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Dominic Cooney
URL:
Keywords: InRadar, LayoutTestFailure, Regression
Depends on:
Blocks: 72352
  Show dependency treegraph
 
Reported: 2011-06-21 20:36 PDT by Yuta Kitamura
Modified: 2022-07-02 22:59 PDT (History)
7 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yuta Kitamura 2011-06-21 20:36:34 PDT
fast/css/font-face-in-shadow-DOM.html is frequently causing IMAGE+TEXT mismatch since around r89397. Maybe r89396?
Comment 1 Yuta Kitamura 2011-06-22 04:33:00 PDT
I don't quite understand this failure yet. CCing some shadow DOM folks for their insights...

http://test-results.appspot.com/dashboards/flakiness_dashboard.html#group=%40ToT%20-%20chromium.org&tests=fast%2Fcss%2Ffont-face-in-shadow-DOM.html
(Scrollbar is sometimes incorrectly rendered)
Comment 2 Jessie Berlin 2011-06-24 11:13:07 PDT
It looks like this test has been failing reliably on Win XP Debug since somewhere in (r89394, r89397].

http://build.webkit.org/builders/Windows%20XP%20Debug%20(Tests)/builds/29858
http://build.webkit.org/builders/Windows%20XP%20Debug%20(Tests)/builds/29859

I have also seen other bugs recently about scrollWidth sometimes being present, and sometimes not. The one that comes to mind is https://bugs.webkit.org/show_bug.cgi?id=63328
Comment 3 Jessie Berlin 2011-06-24 11:29:43 PDT
Add (failing?) expected results for win-xp in http://trac.webkit.org/changeset/89686.
Comment 4 Jessie Berlin 2011-06-24 11:31:46 PDT
<rdar://problem/9671786>
Comment 5 Adam Roben (:aroben) 2011-06-24 11:33:14 PDT
I can reproduce this failure in an XP Debug build using the following command:

run-webkit-tests fast/css/color-leakage.html fast/css/font-face-in-shadow-DOM.html

If I omit the color-leakage.html test, font-face-in-shadow-DOM.html succeeds.
Comment 6 Dominic Cooney 2011-06-24 11:38:42 PDT
Hypothesis: This test depends on the loading of Ahem.ttf. If you run two tests and the previous test does not use Ahem, font-face-in-shadow-DOM.html passes; if the previous test does use Ahem, the test fails.

In fact, you can just run font-face-in-shadow-DOM.html twice in a row. The first one passes, the second one fails.
Comment 7 Jessie Berlin 2011-06-24 11:45:06 PDT
Disabled the test for now so we can get the bots green: http://trac.webkit.org/changeset/89688
Comment 8 Stephen Chenney 2013-04-09 16:11:00 PDT
LayoutTest failures for Chromium are being marked WontFix. The Bug is still accessible and referenced from TestExpectations.
Comment 9 Jessie Berlin 2013-04-09 18:24:53 PDT
Reopening since this bug also tracks Win XP.
Comment 10 Ryosuke Niwa 2022-07-02 22:59:29 PDT
No longer failing on Windows.