Bug 62789 - REGRESSION(r89011): Broke mac build (Requested by vitalyr_ on #webkit).
Summary: REGRESSION(r89011): Broke mac build (Requested by vitalyr_ on #webkit).
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: WebKit Review Bot
URL:
Keywords:
Depends on:
Blocks: 62779
  Show dependency treegraph
 
Reported: 2011-06-16 01:26 PDT by WebKit Review Bot
Modified: 2011-06-16 15:13 PDT (History)
3 users (show)

See Also:


Attachments
ROLLOUT of r89011 (24.58 KB, patch)
2011-06-16 01:26 PDT, WebKit Review Bot
webkit.review.bot: commit-queue?
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description WebKit Review Bot 2011-06-16 01:26:09 PDT
http://trac.webkit.org/changeset/89011 broke the build:
Broke mac build (Requested by vitalyr_ on #webkit).

This is an automatic bug report generated by the sheriff-bot. If this bug
report was created because of a flaky test, please file a bug for the flaky
test (if we don't already have one on file) and dup this bug against that bug
so that we can track how often these flaky tests case pain.

"Only you can prevent forest fires." -- Smokey the Bear
Comment 1 WebKit Review Bot 2011-06-16 01:26:30 PDT
Created attachment 97419 [details]
ROLLOUT of r89011

Any committer can land this patch automatically by marking it commit-queue+.  The commit-queue will build and test the patch before landing to ensure that the rollout will be successful.  This process takes approximately 15 minutes.

If you would like to land the rollout faster, you can use the following command:

  webkit-patch land-attachment ATTACHMENT_ID --ignore-builders

where ATTACHMENT_ID is the ID of this attachment.
Comment 2 Vitaly Repeshko 2011-06-16 01:29:24 PDT
/b/build/slave/webkit-mac-latest-rel/build/src/third_party/WebKit/Source/WebCore/WebCore.gyp/../platform/chromium/ScrollAnimatorChromiumMac.mm: In member function 'virtual void WebCore::ScrollAnimatorChromiumMac::setIsActive(bool)':
/b/build/slave/webkit-mac-latest-rel/build/src/third_party/WebKit/Source/WebCore/WebCore.gyp/../platform/chromium/ScrollAnimatorChromiumMac.mm:1212: error: no matching function for call to 'WebCore::ScrollAnimatorChromiumMac::setIsActive(bool&)'
../platform/ScrollAnimator.h:64: note: candidates are: virtual void WebCore::ScrollAnimator::setIsActive()
/b/build/slave/webkit-mac-latest-rel/build/src/third_party/WebKit/Source/WebCore/WebCore.gyp/../platform/chromium/ScrollAnimatorChromiumMac.mm: In member function 'void WebCore::ScrollAnimatorChromiumMac::updateScrollerStyle()':
/b/build/slave/webkit-mac-latest-rel/build/src/third_party/WebKit/Source/WebCore/WebCore.gyp/../platform/chromium/ScrollAnimatorChromiumMac.mm:1223: error: 'isActive' was not declared in this scope
Comment 3 Vitaly Repeshko 2011-06-16 01:33:56 PDT
Committed r89016: <http://trac.webkit.org/changeset/89016>
Comment 4 Sailesh Agrawal 2011-06-16 15:13:48 PDT
Re-landed a fixed version. See https://bugs.webkit.org/show_bug.cgi?id=62779