Bug 62509 - Factor IconController out of FrameLoader
Summary: Factor IconController out of FrameLoader
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Adam Barth
URL:
Keywords:
Depends on:
Blocks: 29947
  Show dependency treegraph
 
Reported: 2011-06-12 02:34 PDT by Adam Barth
Modified: 2011-06-13 13:36 PDT (History)
4 users (show)

See Also:


Attachments
Patch (42.53 KB, patch)
2011-06-12 02:38 PDT, Adam Barth
no flags Details | Formatted Diff | Diff
Patch (42.57 KB, patch)
2011-06-12 04:11 PDT, Adam Barth
japhet: review+
abarth: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Barth 2011-06-12 02:34:41 PDT
Factor IconController out of FrameLoader
Comment 1 Adam Barth 2011-06-12 02:38:51 PDT
Created attachment 96873 [details]
Patch
Comment 2 WebKit Review Bot 2011-06-12 03:52:47 PDT
Comment on attachment 96873 [details]
Patch

Attachment 96873 [details] did not pass mac-ews (mac):
Output: http://queues.webkit.org/results/8826893
Comment 3 Adam Barth 2011-06-12 04:11:26 PDT
Created attachment 96877 [details]
Patch
Comment 4 Nate Chapin 2011-06-13 11:39:04 PDT
Comment on attachment 96877 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=96877&action=review

This is awesome. Just one question :)

> Source/WebCore/loader/icon/IconController.h:51
> +    KURL url();
> +    IconURLs urls(int iconTypes);

Is there anything we can do to make these names more distinct?
Comment 5 Adam Barth 2011-06-13 11:51:08 PDT
(In reply to comment #4)
> (From update of attachment 96877 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=96877&action=review
> 
> This is awesome. Just one question :)
> 
> > Source/WebCore/loader/icon/IconController.h:51
> > +    KURL url();
> > +    IconURLs urls(int iconTypes);
> 
> Is there anything we can do to make these names more distinct?

Sure.  We can rename urls to urlsForTypes.
Comment 6 Adam Barth 2011-06-13 13:36:08 PDT
Committed r88682: <http://trac.webkit.org/changeset/88682>