Bug 62199 - new-run-webkit-tests: support --repeat-each feature from old-run-webkit-tests
: new-run-webkit-tests: support --repeat-each feature from old-run-webkit-tests
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: Tools / Tests
: 528+ (Nightly build)
: Unspecified Unspecified
: P2 Normal
Assigned To: Eric Seidel
:
Depends on:
Blocks: 64491
  Show dependency treegraph
 
Reported: 2011-06-07 02:39 PDT by Mikhail Naganov
Modified: 2011-11-07 12:42 PST (History)
8 users (show)

See Also:


Attachments
Patch (4.51 KB, patch)
2011-11-06 23:46 PST, Eric Seidel
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mikhail Naganov 2011-06-07 02:39:39 PDT
This is a really useful thing for reproducing flaky test failures. What I'm doing now is replicating my test into a thousand files with different names, and passing them to nwrt.
Comment 1 Eric Seidel 2011-10-27 16:06:46 PDT
*** Bug 65894 has been marked as a duplicate of this bug. ***
Comment 2 Eric Seidel 2011-11-06 23:46:52 PST
Created attachment 113828 [details]
Patch
Comment 3 Eric Seidel 2011-11-06 23:48:24 PST
Dirk: I assume it's kosher that I'm making self._test_files_list out of sync (count-wise) with self._test_files?  I mean, I guess it's not really out of sync since the list would still colapse down to a set, but there are repeats in self._test_files_list.  I assume this approximately matches what NRWT would do if I passed it:

new-run-webkit-tests foo.html foo.html
Comment 4 Dirk Pranke 2011-11-07 11:45:33 PST
Comment on attachment 113828 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=113828&action=review


> Tools/Scripts/webkitpy/layout_tests/controllers/manager.py:507
> +        # FIXME: It's unclear how --repeat-each and --iterations should interact with chunks?

I'd probably just make them mutually exclusive for now. chunks are only used on the bots and aren't likely to need either of those flags.


Change looks fine. I'm cq-'ing it in case you want to make the flags mutually exclusive as I suggest (and possibly add some tests enforcing that). I don't feel strongly about it, however, so you can leave things as-is or just update the fixme to say that you should make them mutually exclusive at some point.
Comment 5 Eric Seidel 2011-11-07 12:25:09 PST
Comment on attachment 113828 [details]
Patch

Thanks for the review!  I think I'll just leave the code as-is for now, and see if anyone complains. :)  I think the behavior as written is reasonable, and probably slightly better than an assert.
Comment 6 WebKit Review Bot 2011-11-07 12:42:49 PST
Comment on attachment 113828 [details]
Patch

Clearing flags on attachment: 113828

Committed r99461: <http://trac.webkit.org/changeset/99461>
Comment 7 WebKit Review Bot 2011-11-07 12:42:54 PST
All reviewed patches have been landed.  Closing bug.