Bug 61720 - REGRESSION(r87618): Causes BrowserFocusTest.FocusOnReload to fail (Requested by abarth|gardener on #webkit).
: REGRESSION(r87618): Causes BrowserFocusTest.FocusOnReload to fail (Requested ...
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: New Bugs
: 528+ (Nightly build)
: Unspecified Unspecified
: P2 Normal
Assigned To: WebKit Review Bot
:
Depends on:
Blocks: 61686
  Show dependency treegraph
 
Reported: 2011-05-30 00:19 PDT by WebKit Review Bot
Modified: 2011-05-30 00:22 PDT (History)
1 user (show)

See Also:


Attachments
ROLLOUT of r87618 (7.24 KB, patch)
2011-05-30 00:20 PDT, WebKit Review Bot
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description WebKit Review Bot 2011-05-30 00:19:43 PDT
http://trac.webkit.org/changeset/87618 broke the build:
Causes BrowserFocusTest.FocusOnReload to fail (Requested by abarth|gardener on #webkit).

This is an automatic bug report generated by the sheriff-bot. If this bug
report was created because of a flaky test, please file a bug for the flaky
test (if we don't already have one on file) and dup this bug against that bug
so that we can track how often these flaky tests case pain.

"Only you can prevent forest fires." -- Smokey the Bear
Comment 1 WebKit Review Bot 2011-05-30 00:20:04 PDT
Created attachment 95327 [details]
ROLLOUT of r87618

Any committer can land this patch automatically by marking it commit-queue+.  The commit-queue will build and test the patch before landing to ensure that the rollout will be successful.  This process takes approximately 15 minutes.

If you would like to land the rollout faster, you can use the following command:

  webkit-patch land-attachment ATTACHMENT_ID --ignore-builders

where ATTACHMENT_ID is the ID of this attachment.
Comment 2 Adam Barth 2011-05-30 00:20:34 PDT
This is the failure:

ASSERTION FAILED: m_cachedLinkResource.get() == resource
third_party/WebKit/Source/WebCore/html/HTMLLinkElement.cpp(461) : virtual void WebCore::HTMLLinkElement::notifyFinished(WebCore::CachedResource*)
Comment 3 Adam Barth 2011-05-30 00:22:25 PDT
Comment on attachment 95327 [details]
ROLLOUT of r87618

Clearing flags on attachment: 95327

Committed r87678: <http://trac.webkit.org/changeset/87678>
Comment 4 Adam Barth 2011-05-30 00:22:28 PDT
All reviewed patches have been landed.  Closing bug.