Bug 61369 - GraphicsContextSkia::drawConvexPolygon doesn't pay attention to shouldAntialias
Summary: GraphicsContextSkia::drawConvexPolygon doesn't pay attention to shouldAntialias
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Platform (show other bugs)
Version: 528+ (Nightly build)
Hardware: All Unspecified
: P3 Normal
Assignee: Nobody
URL:
Keywords:
: 60342 (view as bug list)
Depends on:
Blocks: 60342
  Show dependency treegraph
 
Reported: 2011-05-24 09:45 PDT by Tom Hudson
Modified: 2011-07-27 21:52 PDT (History)
5 users (show)

See Also:


Attachments
Patch (93.76 KB, patch)
2011-05-24 14:17 PDT, Tom Hudson
no flags Details | Formatted Diff | Diff
Patch (577 bytes, patch)
2011-05-25 05:59 PDT, Tom Hudson
no flags Details | Formatted Diff | Diff
Patch (93.84 KB, patch)
2011-05-25 06:20 PDT, Tom Hudson
jamesr: review+
jamesr: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Hudson 2011-05-24 09:45:35 PDT
GraphicsContextSkia::drawConvexPolygon() ignores the shouldAntialias.
The CG & Qt implementations both do obey it.
The effect is that Skia/Chromium does *too much* antialiasing, particularly on the vertical edges of table cells where WebKit is telling us not to antialias.
Comment 1 Tom Hudson 2011-05-24 14:17:02 PDT
Created attachment 94685 [details]
Patch
Comment 2 Tom Hudson 2011-05-25 05:59:11 PDT
Created attachment 94772 [details]
Patch
Comment 3 Tom Hudson 2011-05-25 06:20:59 PDT
Created attachment 94776 [details]
Patch
Comment 4 James Robinson 2011-05-25 12:23:57 PDT
Comment on attachment 94776 [details]
Patch

Patch looks good.  Not touching c-q flag yet, lemme scheme with Dimitri about how to land this.
Comment 5 James Robinson 2011-05-25 12:26:36 PDT
Comment on attachment 94776 [details]
Patch

cq-, we're gonna have to land this manually
Comment 6 Eric Seidel (no email) 2011-06-18 20:02:18 PDT
Any update?  This was marked for manual landing nearly a month ago.
Comment 7 Tom Hudson 2011-06-20 05:38:20 PDT
(In reply to comment #6)
> Any update?  This was marked for manual landing nearly a month ago.

At that time the gardener held off landing it because they didn't want to disable so many tests. I assume that I need a committer to work with, and don't have one in my local office.
Comment 8 James Robinson 2011-06-20 12:55:06 PDT
Hi, sorry.  This patch is good to land but will require a good amount of manual work by committers post-landing to deal with unexpected image failures and to rebaseline the expected image diffs.  I was hoping (as it turns out optimistically) that I'd have some time to help get this landed, but that's seeming unrealistic.  Anyone who feels comfortable handling the pixel test rebaselines should feel free to land this at any time (but please coordinate with the chromium WebKit gardener).
Comment 9 James Robinson 2011-07-10 20:18:28 PDT
Landed http://trac.webkit.org/changeset/90701, rebaselining has begun.
Comment 11 Ben Wells 2011-07-27 21:52:44 PDT
*** Bug 60342 has been marked as a duplicate of this bug. ***