Bug 60760 - MediaElements fails to load the data in some cases.
Summary: MediaElements fails to load the data in some cases.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media Elements (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P1 Critical
Assignee: Alexis Menard (darktears)
URL: http://slides.html5rocks.com/#video-a...
Keywords: Qt, QtTriaged
: 60465 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-05-13 06:07 PDT by Alexis Menard (darktears)
Modified: 2011-05-19 13:44 PDT (History)
9 users (show)

See Also:


Attachments
Patch (1.98 KB, patch)
2011-05-13 06:11 PDT, Alexis Menard (darktears)
no flags Details | Formatted Diff | Diff
Patch (5.08 KB, patch)
2011-05-18 12:34 PDT, Alexis Menard (darktears)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexis Menard (darktears) 2011-05-13 06:07:26 PDT
When going to http://slides.html5rocks.com/#video-audio with the GTK port or Qt port using MediaPlayerGStreamer the video fails to load in some cases (basically depending on some timing regarding how the rendertree is constructed).
Comment 1 Alexis Menard (darktears) 2011-05-13 06:11:38 PDT
Created attachment 93440 [details]
Patch
Comment 2 Alexis Menard (darktears) 2011-05-13 06:12:28 PDT
(In reply to comment #1)
> Created an attachment (id=93440) [details]
> Patch

Looking for feedback for this patch :D. Should I also remove the similar call in RenderVideo, I believe it's not needed after that patch.
Comment 3 Alexis Menard (darktears) 2011-05-13 06:18:08 PDT
Comment on attachment 93440 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=93440&action=review

> Source/WebCore/ChangeLog:14
> +        network context). At least the bug can be reproduce with Qt and GTK.

reproduced :D. Will fix.
Comment 4 Simon Hausmann 2011-05-13 07:46:12 PDT
You can find an alternative solution that only touches the gstreamer back-end at
https://gitorious.org/+qtwebkit-webkit2-dev/webkit/qtwebkit-webkit2-dev/commit/7ae683e548a09cbec9f0e97e89a5e482f1fa9b74
Comment 5 Alexis Menard (darktears) 2011-05-13 08:27:15 PDT
(In reply to comment #4)
> You can find an alternative solution that only touches the gstreamer back-end at
> https://gitorious.org/+qtwebkit-webkit2-dev/webkit/qtwebkit-webkit2-dev/commit/7ae683e548a09cbec9f0e97e89a5e482f1fa9b74

Yep, I thought about that too but I felt the problem could happen to anyone in fact.
Comment 6 Philippe Normand 2011-05-13 10:56:42 PDT
Comment on attachment 93440 [details]
Patch

I think this patch makes sense indeed, would it be possible to have a layout test for it?
Comment 7 Simon Hausmann 2011-05-16 00:24:54 PDT
(In reply to comment #5)
> (In reply to comment #4)
> > You can find an alternative solution that only touches the gstreamer back-end at
> > https://gitorious.org/+qtwebkit-webkit2-dev/webkit/qtwebkit-webkit2-dev/commit/7ae683e548a09cbec9f0e97e89a5e482f1fa9b74
> 
> Yep, I thought about that too but I felt the problem could happen to anyone in fact.

I agree that this can happen to others, too, but I think it's wrong of the others to use FrameView. IMHO it's cleaner to use the MediaPlayer* APIs in the MediaPlayer back-end implementation than WebCore::FrameView.
Comment 8 Alexis Menard (darktears) 2011-05-17 07:53:16 PDT
*** Bug 60465 has been marked as a duplicate of this bug. ***
Comment 9 Alexis Menard (darktears) 2011-05-18 12:34:23 PDT
Created attachment 93967 [details]
Patch
Comment 10 WebKit Commit Bot 2011-05-18 14:26:18 PDT
Comment on attachment 93967 [details]
Patch

Clearing flags on attachment: 93967

Committed r86790: <http://trac.webkit.org/changeset/86790>
Comment 11 WebKit Commit Bot 2011-05-18 14:26:22 PDT
All reviewed patches have been landed.  Closing bug.
Comment 12 Ademar Reis 2011-05-19 13:44:30 PDT
Revision r86790 cherry-picked into qtwebkit-2.2 with commit e309ebe <http://gitorious.org/webkit/qtwebkit/commit/e309ebe>