Bug 60629 - Implement plugin process for UNIX platform
Summary: Implement plugin process for UNIX platform
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P2 Normal
Assignee: Nobody
URL:
Keywords: Gtk, Qt, QtTriaged
: 57617 (view as bug list)
Depends on:
Blocks: 57617 58223 60546 60621 61065
  Show dependency treegraph
 
Reported: 2011-05-11 08:22 PDT by Carlos Garcia Campos
Modified: 2011-08-25 01:16 PDT (History)
6 users (show)

See Also:


Attachments
Patch (11.45 KB, patch)
2011-05-11 08:27 PDT, Carlos Garcia Campos
no flags Details | Formatted Diff | Diff
Updated patch (12.42 KB, patch)
2011-05-13 01:03 PDT, Carlos Garcia Campos
no flags Details | Formatted Diff | Diff
Updated patch (12.55 KB, patch)
2011-06-06 05:53 PDT, Carlos Garcia Campos
andersca: review+
gyuyoung.kim: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Garcia Campos 2011-05-11 08:22:10 PDT
Patch attached to bug #57617 contains some parts needed to implement the plugin process that are common to unix platforms.
Comment 1 Carlos Garcia Campos 2011-05-11 08:27:57 PDT
Created attachment 93120 [details]
Patch

This patch contains the common parts needed to implement the plugin process for unix. It's mostly the same patch written by Balazs Kelemen in bug #57617.
Comment 2 Carlos Garcia Campos 2011-05-13 01:03:25 PDT
Created attachment 93415 [details]
Updated patch

Remove assertions that check that the Handle is not null. In PluginProxy::geometryDidChange we pass a null Handle if we do not need to allocate a new backing store.
Comment 3 Balazs Kelemen 2011-05-13 08:15:42 PDT
(In reply to comment #2)
> Created an attachment (id=93415) [details]
> Updated patch
> 
> Remove assertions that check that the Handle is not null. In PluginProxy::geometryDidChange we pass a null Handle if we do not need to allocate a new backing store.

It's in conflict with your comment there: https://bugs.webkit.org/show_bug.cgi?id=57617#c19. Is the patch obsolete now?
Comment 4 Carlos Garcia Campos 2011-05-15 23:56:07 PDT
(In reply to comment #3)
> (In reply to comment #2)
> > Created an attachment (id=93415) [details] [details]
> > Updated patch
> > 
> > Remove assertions that check that the Handle is not null. In PluginProxy::geometryDidChange we pass a null Handle if we do not need to allocate a new backing store.
> 
> It's in conflict with your comment there: https://bugs.webkit.org/show_bug.cgi?id=57617#c19. Is the patch obsolete now?

Yes, see bug https://bugs.webkit.org/show_bug.cgi?id=60621
Comment 5 Carlos Garcia Campos 2011-05-16 05:33:53 PDT
(In reply to comment #4)
> (In reply to comment #3)
> > (In reply to comment #2)
> > > Created an attachment (id=93415) [details] [details] [details]
> > > Updated patch
> > > 
> > > Remove assertions that check that the Handle is not null. In PluginProxy::geometryDidChange we pass a null Handle if we do not need to allocate a new backing store.
> > 
> > It's in conflict with your comment there: https://bugs.webkit.org/show_bug.cgi?id=57617#c19. Is the patch obsolete now?
> 
> Yes, see bug https://bugs.webkit.org/show_bug.cgi?id=60621

Just to clarify, I didn't answer your question, sorry, the changelog text is in conflict with my comment, but the patch is not obsolete, patch attached to bug #60621 allows to send null handles.
Comment 6 Carlos Garcia Campos 2011-06-06 05:53:40 PDT
Created attachment 96081 [details]
Updated patch

Since r88147 the GTK port uses STREAM sockets, so I've updated the patch to use STREAM sockets in the plugin process too for the GTK port.
Comment 7 Gyuyoung Kim 2011-06-06 08:20:54 PDT
Comment on attachment 96081 [details]
Updated patch

Attachment 96081 [details] did not pass efl-ews (efl):
Output: http://queues.webkit.org/results/8766865
Comment 8 Anders Carlsson 2011-07-14 08:18:58 PDT
Comment on attachment 96081 [details]
Updated patch

Ideally I'd like to see a generic, cross-platform way to send a connection endpoint over another connection. However, this is fine for now!
Comment 9 Carlos Garcia Campos 2011-07-14 10:44:47 PDT
Committed r91013: <http://trac.webkit.org/changeset/91013>
Comment 10 Balazs Kelemen 2011-08-25 01:16:28 PDT
*** Bug 57617 has been marked as a duplicate of this bug. ***