Bug 60505 - REGRESSION(r86039): DragCaretController doesn't draw caret
Summary: REGRESSION(r86039): DragCaretController doesn't draw caret
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML Editing (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Ryosuke Niwa
URL:
Keywords:
Depends on: 60273
Blocks: 60454
  Show dependency treegraph
 
Reported: 2011-05-09 14:30 PDT by Ryosuke Niwa
Modified: 2011-05-09 16:37 PDT (History)
1 user (show)

See Also:


Attachments
reverts r86039 in setCaretPosition (1.85 KB, patch)
2011-05-09 15:45 PDT, Ryosuke Niwa
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ryosuke Niwa 2011-05-09 14:30:56 PDT
Apparently, an early exit added in r86039 causes drag caret to be not drawn.
Comment 1 Darin Adler 2011-05-09 15:27:23 PDT
Since we *just* introduced this, I suggest rolling out the early exit quickly, then at leisure looking more deeply at the causes.
Comment 2 Ryosuke Niwa 2011-05-09 15:38:26 PDT
(In reply to comment #1)
> Since we *just* introduced this, I suggest rolling out the early exit quickly, then at leisure looking more deeply at the causes.

Definitely.  I just wasted much time fighting with the bug 60506 but I'll submit a patch shortly without a test.
Comment 3 Ryosuke Niwa 2011-05-09 15:45:04 PDT
Created attachment 92870 [details]
reverts r86039 in setCaretPosition
Comment 4 Ryosuke Niwa 2011-05-09 16:37:07 PDT
Comment on attachment 92870 [details]
reverts r86039 in setCaretPosition

Clearing flags on attachment: 92870

Committed r86104: <http://trac.webkit.org/changeset/86104>
Comment 5 Ryosuke Niwa 2011-05-09 16:37:10 PDT
All reviewed patches have been landed.  Closing bug.