tx/ty offsets used in painting are confusing and should be combined into either an IntSize or IntPoint -- likely IntSize. See the URL for a related discussion from WebKit-Dev.
Considering how frequently tx/ty are used to construct points AND sizes, I now feel like this could warrant a new type to avoid the mess of calling this an point or size then repeatedly using it another way. Perhaps PaintOffset/IntOffset, which would allow easy conversion to points and sizes.
Updating with the name and making this a meta bug to track all the changes that'll help us make this switch.
We already have a metabug tracking this work, and we ended up using IntPoint instead of IntSize.