Bug 59729 - Add ENABLE macro for WebKitAnimation
Summary: Add ENABLE macro for WebKitAnimation
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 528+ (Nightly build)
Hardware: All OS X 10.5
: P2 Normal
Assignee: Dean Jackson
URL:
Keywords: InRadar
: 59730 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-04-28 12:47 PDT by Dean Jackson
Modified: 2011-04-29 14:10 PDT (History)
2 users (show)

See Also:


Attachments
Patch (24.67 KB, patch)
2011-04-29 09:50 PDT, Dean Jackson
simon.fraser: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dean Jackson 2011-04-28 12:47:50 PDT
The WebKitAnimation API is not fully baked. Add an ENABLE so that ports can disable it easily.


<rdar://problem/9353599>
Comment 1 Simon Fraser (smfr) 2011-04-28 12:50:41 PDT
*** Bug 59730 has been marked as a duplicate of this bug. ***
Comment 2 Dean Jackson 2011-04-29 09:50:39 PDT
Created attachment 91692 [details]
Patch
Comment 3 Dean Jackson 2011-04-29 11:15:39 PDT
http://trac.webkit.org/changeset/85340
Comment 4 Eric Seidel (no email) 2011-04-29 13:41:00 PDT
Per the guidelines discussed at webkit-meeting (and on webkit-reviewers) someone should probably announce this new feature to the list.  I would point you to the webkit.org doc on this, except it hasn't landed yet. :)
https://bugs.webkit.org/show_bug.cgi?id=59672
Comment 5 Dean Jackson 2011-04-29 14:10:41 PDT
Thanks Eric. Email sent.