Bug 59448 - [Navigation Timing] navigationStart should always be available
: [Navigation Timing] navigationStart should always be available
Status: RESOLVED FIXED
: WebKit
WebCore Misc.
: 528+ (Nightly build)
: PC Mac OS X 10.5
: P2 Normal
Assigned To:
:
:
:
: 30685
  Show dependency treegraph
 
Reported: 2011-04-26 05:07 PST by
Modified: 2011-05-05 16:06 PST (History)


Attachments
Patch (4.83 KB, patch)
2011-05-03 10:16 PST, Tony Gentilcore
no flags Review Patch | Details | Formatted Diff | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2011-04-26 05:07:40 PST
performance.timing.navigationStart should no longer be zeroed after a cross origin redirect. See:
http://dvcs.w3.org/hg/webperf/rev/7f6093709aee
------- Comment #1 From 2011-04-26 05:08:57 PST -------
This is basically a partial revert of bug 55068
------- Comment #2 From 2011-05-03 10:16:20 PST -------
Created an attachment (id=92087) [details]
Patch
------- Comment #3 From 2011-05-03 10:18:01 PST -------
LGTM
------- Comment #4 From 2011-05-03 10:25:48 PST -------
Fishing for an r+
------- Comment #5 From 2011-05-04 13:58:55 PST -------
More reviewer fishing...
------- Comment #6 From 2011-05-05 13:30:24 PST -------
(From update of attachment 92087 [details])
Clearing flags on attachment: 92087

Committed r85873: <http://trac.webkit.org/changeset/85873>
------- Comment #7 From 2011-05-05 13:30:29 PST -------
All reviewed patches have been landed.  Closing bug.
------- Comment #8 From 2011-05-05 16:06:57 PST -------
http://trac.webkit.org/changeset/85873 might have broken GTK Linux 32-bit Debug
The following tests are not passing:
svg/W3C-SVG-1.1/animate-elem-46-t.svg