Bug 59019 - Enable the interactive form validation feature by default
: Enable the interactive form validation feature by default
Status: RESOLVED WONTFIX
Product: WebKit
Classification: Unclassified
Component: Forms
: 528+ (Nightly build)
: All All
: P2 Normal
Assigned To: Nobody
:
Depends on: 44436 55995 56901
Blocks: 28649
  Show dependency treegraph
 
Reported: 2011-04-20 12:46 PDT by Kent Tamura
Modified: 2013-01-22 20:51 PST (History)
8 users (show)

See Also:


Attachments
Patch (11.93 KB, patch)
2011-04-20 15:06 PDT, Kent Tamura
ap: review-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kent Tamura 2011-04-20 12:46:15 PDT
We disabled the interactive form validation feature because the implementation was incomplete and there were some compatibility issues. See Bug 40218 and Bug 40520.

We implemented the validation message bubble, Google Chrome 10 was released on March 9 with the interactive form validation feature enabled, and I didn't see many compatibility issues.  Also, Firefox 4 was released with the interactive form validation feature.

I'd like to enable the interactive form validation feature by default.
Comment 1 Alexey Proskuryakov 2011-04-20 13:38:58 PDT
Is bug 44436 somehow fixed now?
Comment 2 Kent Tamura 2011-04-20 14:23:09 PDT
(In reply to comment #1)
> Is bug 44436 somehow fixed now?

As for required=no, I think there are no way to fix the issue other than introducing a site specific quirk.
Comment 3 Kent Tamura 2011-04-20 15:06:04 PDT
Created attachment 90422 [details]
Patch
Comment 4 Maciej Stachowiak 2011-04-20 16:32:37 PDT
We're planning to leave the feature off in Safari for the near, since the UI design is not up to our standards. We would like to revise the UI before we turn it on in anything we ship. Therefore, we'd prefer for this feature to stay disabled for now, at lead for ports shipped by Apple.
Comment 5 Alexey Proskuryakov 2011-04-20 16:34:45 PDT
Comment on attachment 90422 [details]
Patch

As far as being enabled on trunk goes, I don't think that this can be landed without fixing bug 44436 first. That is a hugely important single page!

Discussions of how to fix 44436 should go into that bug, of course.
Comment 6 Kent Tamura 2012-09-19 16:29:04 PDT
*** Bug 97085 has been marked as a duplicate of this bug. ***
Comment 7 Kent Tamura 2013-01-22 20:51:52 PST
Because I don't recommend to use platform-independent validation message UI with Shadow DOM, enabling the feature by default is not reasonable.