Bug 5865 - SVG Lighting gets y component of normals the wrong way round with some images.
Summary: SVG Lighting gets y component of normals the wrong way round with some images.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P4 Normal
Assignee: Nobody
URL:
Keywords: NeedsReduction
: 16714 (view as bug list)
Depends on:
Blocks: 68469 26389
  Show dependency treegraph
 
Reported: 2005-11-28 17:30 PST by Oliver Hunt
Modified: 2014-05-12 05:54 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Hunt 2005-11-28 17:30:24 PST
Okay, if we look at http://www.w3.org/Graphics/SVG/Test/20030813/htmlframe/full-filters-light-01-
f.html we can see that all the images produced by the current lighting filters is correct, but if we look at 
http://www.w3.org/TR/2002/CR-SVG11-20020430/images/filters/filters01.svg the light appears to be 
come from below, rather than from above, as it should.
Comment 1 Eric Seidel (no email) 2006-01-26 14:52:00 PST
It's not clear to me that the lighting "comes from below" as you suggest.  Please add additional information to this bug (preferably as a test case).
Comment 2 Oliver Hunt 2006-01-26 15:30:06 PST
If you compare the svg http://www.w3.org/TR/2002/CR-SVG11-20020430/images/filters/filters01.svg to the expected output:
http://www.w3.org/TR/2002/CR-SVG11-20020430/images/filters/filters01.png

You can see that there is a significant difference in the highlights -- in the svg the highlight is towards the bottom of the rendered image.  In the png it is towards the top.   

There are some not insignificant differences in the overall colour of the rendered image, but i'm currently attributing these to a combination of colour matching and a slightly incorrect gaussian blur.
Comment 3 Eric Seidel (no email) 2006-01-26 15:44:17 PST
Marking this as a P4 as this is not a very user-visable issue.
Comment 4 Eric Seidel (no email) 2008-01-05 00:56:01 PST
*** Bug 16714 has been marked as a duplicate of this bug. ***
Comment 5 Nikolas Zimmermann 2010-07-01 02:13:09 PDT
This is long invalid. We don't even have the CI based filters anymore.