Bug 58590 - media/video-controls-transformed.html is broken
Summary: media/video-controls-transformed.html is broken
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC All
: P2 Normal
Assignee: Ami Fischman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-14 15:51 PDT by Ami Fischman
Modified: 2011-05-03 02:13 PDT (History)
3 users (show)

See Also:


Attachments
Stop hard-coding pixel values. (3.25 KB, patch)
2011-04-14 15:54 PDT, Ami Fischman
no flags Details | Formatted Diff | Diff
CR1 responses. (3.32 KB, patch)
2011-04-25 21:05 PDT, Ami Fischman
no flags Details | Formatted Diff | Diff
CR2 responses. (3.37 KB, patch)
2011-04-26 11:42 PDT, Ami Fischman
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ami Fischman 2011-04-14 15:51:10 PDT
media/video-controls-transformed.html is ignored by all ports, and is broken because it hard-coded click locations for a control that varies by port (and has moved within ports, too).
Comment 1 Ami Fischman 2011-04-14 15:54:18 PDT
Created attachment 89677 [details]
Stop hard-coding pixel values.
Comment 2 David Levin 2011-04-15 14:03:36 PDT
Comment on attachment 89677 [details]
Stop hard-coding pixel values.

View in context: https://bugs.webkit.org/attachment.cgi?id=89677&action=review

> LayoutTests/media/video-controls-transformed.html:22
> +                // This hard-codes the contruction order of the media controls,

typo: contruction

> LayoutTests/media/video-controls-transformed.html:23
> +                // but is currently the only way to do it.  http://webk.it/58584

typo: "but is" (Perhaps "but that is")
typo: http://webk.it/58584
Comment 3 Ami Fischman 2011-04-25 21:03:55 PDT
(In reply to comment #2)
> (From update of attachment 89677 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=89677&action=review
> 
> > LayoutTests/media/video-controls-transformed.html:22
> > +                // This hard-codes the contruction order of the media controls,
> 
> typo: contruction

Done.

> > LayoutTests/media/video-controls-transformed.html:23
> > +                // but is currently the only way to do it.  http://webk.it/58584
> 
> typo: "but is" (Perhaps "but that is")

I think the previous version was grammatically correct, but attempted a clarification.

> typo: http://webk.it/58584

What's the typo?
Comment 4 Ami Fischman 2011-04-25 21:05:31 PDT
Created attachment 91050 [details]
CR1 responses.
Comment 5 David Levin 2011-04-25 23:03:15 PDT
Comment on attachment 91050 [details]
CR1 responses.

View in context: https://bugs.webkit.org/attachment.cgi?id=91050&action=review

> LayoutTests/media/video-controls-transformed.html:24
> +                // way to do it.  http://webk.it/58584 is tracking fixing that.

Cute: webk.it but it doesn't feel like it belongs in code like this when it really isn't controlled by the project. (It seems odd to me at least.)
Comment 6 Ami Fischman 2011-04-26 11:42:08 PDT
Created attachment 91133 [details]
CR2 responses.
Comment 7 WebKit Commit Bot 2011-04-26 22:07:38 PDT
Comment on attachment 91133 [details]
CR2 responses.

Clearing flags on attachment: 91133

Committed r85015: <http://trac.webkit.org/changeset/85015>
Comment 8 WebKit Commit Bot 2011-04-26 22:07:43 PDT
All reviewed patches have been landed.  Closing bug.
Comment 9 Philippe Normand 2011-05-03 02:13:03 PDT
*** Bug 50706 has been marked as a duplicate of this bug. ***