Bug 58363 - Use new skia API for wrapping DrawingBuffer's FBO/Tex IDs in skia object
Summary: Use new skia API for wrapping DrawingBuffer's FBO/Tex IDs in skia object
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Platform (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC All
: P2 Normal
Assignee: Brian Salomon
URL:
Keywords:
: 58357 58358 58360 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-04-12 12:45 PDT by Brian Salomon
Modified: 2011-04-13 07:34 PDT (History)
6 users (show)

See Also:


Attachments
Patch (3.91 KB, patch)
2011-04-12 13:28 PDT, Brian Salomon
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Salomon 2011-04-12 12:45:26 PDT
Use new skia API for wrapping DrawingBuffer's FBO/Tex IDs in skia object
Comment 1 Brian Salomon 2011-04-12 13:28:30 PDT
Created attachment 89259 [details]
Patch
Comment 2 Brian Salomon 2011-04-12 13:29:38 PDT
*** Bug 58357 has been marked as a duplicate of this bug. ***
Comment 3 Brian Salomon 2011-04-12 13:30:01 PDT
*** Bug 58358 has been marked as a duplicate of this bug. ***
Comment 4 Brian Salomon 2011-04-12 13:30:22 PDT
*** Bug 58360 has been marked as a duplicate of this bug. ***
Comment 5 Kenneth Russell 2011-04-12 13:48:34 PDT
Comment on attachment 89259 [details]
Patch

Looks fine to me assuming it's been tested.
Comment 6 Brian Salomon 2011-04-13 05:41:08 PDT
Comment on attachment 89259 [details]
Patch

The chrome DEPS roll that this change is dependent on has been committed. This change should be ready to go in. (I tested it locally with ENABLE(SKIA_GPU) turned on.)
Comment 7 WebKit Commit Bot 2011-04-13 07:33:54 PDT
Comment on attachment 89259 [details]
Patch

Clearing flags on attachment: 89259

Committed r83733: <http://trac.webkit.org/changeset/83733>
Comment 8 WebKit Commit Bot 2011-04-13 07:34:00 PDT
All reviewed patches have been landed.  Closing bug.