Bug 58195 - new-run-webkit-tests: implement support for audio, take two
Summary: new-run-webkit-tests: implement support for audio, take two
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other OS X 10.5
: P2 Normal
Assignee: Dirk Pranke
URL:
Keywords:
Depends on:
Blocks: 58196
  Show dependency treegraph
 
Reported: 2011-04-09 19:11 PDT by Dirk Pranke
Modified: 2022-02-27 23:42 PST (History)
6 users (show)

See Also:


Attachments
Patch (36.87 KB, patch)
2011-04-09 19:28 PDT, Dirk Pranke
tony: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk Pranke 2011-04-09 19:11:19 PDT
new-run-webkit-tests: implement support for audio, take two
Comment 1 Dirk Pranke 2011-04-09 19:28:01 PDT
Created attachment 88940 [details]
Patch
Comment 2 Dirk Pranke 2011-04-09 19:32:08 PDT
Comment on attachment 88940 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=88940&action=review

This is a revised version of the patch(es) landed in bug 58101. Those patches were rolled out because they were crashing new-run-webkit-tests.

The regression turned out to be a result of passing None instead of '' to Port.diff_image(). I have added comments to show the diffs from the previous patch.

> Tools/Scripts/webkitpy/layout_tests/port/chromium.py:143
> +            return True

This chunk is the fix for the crash on diff_image() in chromium ports. This really needs unit tests, but to test it properly requires changing too many other things, so I'll post the unit tests in a separate patch for clarity.

> Tools/Scripts/webkitpy/layout_tests/port/webkit.py:115
> +        if not actual_contents or not expected_contents:

And this is the fix for the webkit-base ports. Again, I will post unit tests in a separate patch for clarity.
Comment 3 Dirk Pranke 2011-04-09 19:52:10 PDT
unit tests posted in bug 58196.
Comment 4 Dirk Pranke 2011-04-11 12:18:13 PDT
Committed r83475: <http://trac.webkit.org/changeset/83475>