Bug 57910 - Rename CSSKeyframesRule insertRule to appendRule
Summary: Rename CSSKeyframesRule insertRule to appendRule
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: All OS X 10.5
: P2 Normal
Assignee: Dean Jackson
URL:
Keywords: InRadar
: 133746 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-04-05 18:00 PDT by Dean Jackson
Modified: 2014-09-25 17:03 PDT (History)
4 users (show)

See Also:


Attachments
Patch (3.63 KB, patch)
2014-09-25 15:58 PDT, Said Abou-Hallawa
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dean Jackson 2011-04-05 18:00:54 PDT
The spec renamed the method. Make sure we don't remove the existing insertRule though, in case people are using it.
Comment 1 Dean Jackson 2011-04-05 18:02:00 PDT
<rdar://problem/9237118>
Comment 2 Sylvain Galineau 2014-07-19 12:02:53 PDT
*** Bug 133746 has been marked as a duplicate of this bug. ***
Comment 3 Said Abou-Hallawa 2014-09-25 12:59:56 PDT
I have a fix for this bug.  The interface WebKitCSSKeyframesRule.idl and the class WebKitCSSKeyframesRule need to have a new method called 'appendRule' which is basically and alias of InsertRule().
Comment 4 Said Abou-Hallawa 2014-09-25 15:58:48 PDT
Created attachment 238680 [details]
Patch
Comment 5 WebKit Commit Bot 2014-09-25 17:03:45 PDT
Comment on attachment 238680 [details]
Patch

Clearing flags on attachment: 238680

Committed r173982: <http://trac.webkit.org/changeset/173982>
Comment 6 WebKit Commit Bot 2014-09-25 17:03:49 PDT
All reviewed patches have been landed.  Closing bug.