Bug 57030 - REGRESSION (r81782): http/tests/inspector/extensions-resources-redirect.html sometimes crashes WebKit2's web process while handling a WebIconDatabaseProxy::ReceivedIconLoadDecision message
: REGRESSION (r81782): http/tests/inspector/extensions-resources-redirect.html ...
Status: RESOLVED FIXED
: WebKit
WebKit2
: 528+ (Nightly build)
: Macintosh Mac OS X 10.6
: P2 Normal
Assigned To:
: http://build.webkit.org/results/SnowL...
: InRadar, LayoutTestFailure
:
:
  Show dependency treegraph
 
Reported: 2011-03-24 09:55 PST by
Modified: 2011-03-24 13:23 PST (History)


Attachments
Fix WebCore and unskip the test (3.56 KB, patch)
2011-03-24 13:17 PST, Brady Eidson
aroben: review+
Review Patch | Details | Formatted Diff | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2011-03-24 09:55:54 PST
http/tests/inspector/extensions-resources-redirect.html sometimes crashes WebKit2's web process. We know this because the web process crashing then causes the UI process to crash (bug 57029). We don't know what's causing the web process to crash, though, because the UI process crash is masking it.
------- Comment #1 From 2011-03-24 10:00:10 PST -------
Ooh, I found a crash log from the web process. See the URL.
------- Comment #2 From 2011-03-24 10:04:47 PST -------
Looks like the first time this happened was in r81782, which seems like a related change.

http://build.webkit.org/builders/SnowLeopard%20Intel%20Release%20%28WebKit2%20Tests%29/builds/9955
------- Comment #3 From 2011-03-24 10:05:09 PST -------
Added the test to the mac-wk2 Skipped file in r81874.
------- Comment #4 From 2011-03-24 10:07:38 PST -------
<rdar://problem/9182074>
------- Comment #5 From 2011-03-24 13:08:18 PST -------
Figured this out.

A serious of events have to happen with both the network layer and the WebProcess -> UIProcess layer to reproduce this.  There's probably no practical way to reproduce the exact conditions necessary in layout-test land, but we obviously already had coverage that caught this.

In fact, the single test Adam deactivated isn't the only one that can cause this - I've seen it locally with other https tests (though less frequently)

Patch is coming soon.
------- Comment #6 From 2011-03-24 13:17:20 PST -------
Created an attachment (id=86819) [details]
Fix WebCore and unskip the test
------- Comment #7 From 2011-03-24 13:23:20 PST -------
r81892