Bug 57029 - Crash in DrawingAreaProxyImpl::visibilityDidChange after web process crashes when running http/tests/inspector/extensions-resources-redirect.html
Summary: Crash in DrawingAreaProxyImpl::visibilityDidChange after web process crashes ...
Status: RESOLVED DUPLICATE of bug 58271
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.6
: P2 Normal
Assignee: Nobody
URL: http://build.webkit.org/results/SnowL...
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2011-03-24 09:54 PDT by Adam Roben (:aroben)
Modified: 2011-04-12 05:00 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Roben (:aroben) 2011-03-24 09:54:04 PDT
http/tests/inspector/extensions-resources-redirect.html seems to sometimes cause the web process to crash. When this happens, the UI process then crashes in DrawingAreaProxyImpl::visibilityDidChange. See the URL for the crash log.
Comment 1 Adam Roben (:aroben) 2011-03-24 10:05:50 PDT
Bug 57030 covers the cause of the web process crash. The crashing test has now been added to the mac-wk2 Skipped file. But clearly there's still a UI process bug here.
Comment 2 Adam Roben (:aroben) 2011-03-24 10:07:18 PDT
<rdar://problem/9182073>
Comment 3 Adam Roben (:aroben) 2011-04-12 05:00:08 PDT
Anders says this was fixed in r83509.

*** This bug has been marked as a duplicate of bug 58271 ***