Bug 53753 - [Qt] Blue background is displayed when user taps on Text Label
Summary: [Qt] Blue background is displayed when user taps on Text Label
Status: RESOLVED DUPLICATE of bug 38520
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: S60 Hardware S60 3rd edition
: P3 Normal
Assignee: Nobody
URL:
Keywords: Qt, QtTriaged
Depends on:
Blocks:
 
Reported: 2011-02-03 20:50 PST by vignesh
Modified: 2011-02-04 15:12 PST (History)
1 user (show)

See Also:


Attachments
HTML file to reproduce the issue. (276 bytes, text/html)
2011-02-04 12:41 PST, Prasad
no flags Details
Screen shot -1 (6.96 KB, image/png)
2011-02-04 12:41 PST, Prasad
no flags Details
Screen shot -2 (7.06 KB, image/png)
2011-02-04 12:42 PST, Prasad
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description vignesh 2011-02-03 20:50:30 PST
Blue background is displayed when user taps on Text Label. 
Vasco PS2 : SSO DE goes live part of Store in Wk08. 
This is a blocker issue for SSO DE.

Please see the mail chain - CWRT Confirmed to raise it on Webkit

Raghu 2011-01-04 04:14:53 EST

Created attachment 9228 [details]
password test widget and screenshots attached for reference

Precondition:
On Vasco Wk 52, Install the sample test widget.

Steps 
launch the sample test widget
Tap on the username text label.
Tap on Password text label

Expected Result:
Text label background should not be highlighted.

Actual Result:
Text label is highlighted with blue background on both username and password
text labels.

Refer screen shots for details

[reply] [-] Comment 1 Krishna 2011-01-14 09:54:55 EST

Mostly QtWebkit issue. To be further filtered and moved to webkit.org as per
the QtWebkit filtering process.

[reply] [-] Comment 2 Latha Devaiah 2011-01-20 03:36:59 EST

Retested on the PS2 NB -
"\\bsetpfs1\wrtsvr\qtwrt\qtwrt_1.0.1\symbian\9.2\qtwrt_qtwrt_1.0.1_r47255_9.2wk02.zip"
and unable to reproduce the bug. 

The username and password labels does not get highlighted with blue background
when tapping on the text field.

Platform Location:
\\bhsmb002.apac.nokia.com\hydra\s60_devices_sw\DFS7x.92\92_201102_hw79

Hence marking the bug as "Worksforme"

[reply] [-] Comment 3 Prasad Adimulam 2011-01-20 11:46:46 EST

Re-tested with the Wk02 platform release + wk02 UDA image on the vasco device
with the attached widget and the issue is NOT REPRODUCIBLE.

[reply] [-] Comment 4 Raghu 2011-01-27 01:14:13 EST

Created attachment 9467 [details]
Latest screenshot video on Password widget

[reply] [-] Comment 5 Raghu 2011-01-27 01:14:37 EST

This issue is Still reproducible on Wk 03.
Tested this on the password test widget.
Attaching video screen shot for reference.
This video screenshot captures the issue occuring on Password widget and on
SSOUI client application

Also this issue is NOT reproducible on Vasco WK46_PS1.

[reply] [-] Comment 6 Krishna 2011-02-02 08:08:25 EST

Prasad - If this is reproducible on the latest 9.2 PS2 nihgtly or IDO build,
also coninue test for whether this is a QtWebkit issue. If this is a QtWebkit
issue, please clone to webkit.org Bugzilla.

The priority also needs to be upgraded to P2 if this is reproducible.

[reply] [-] Comment 7 Krishna 2011-02-02 10:01:21 EST

Prasad - And please assign back to WRT Error Manager Murali Alluri for further
action.

[reply] [-] Comment 8 Prasad Adimulam 2011-02-03 16:52:22 EST

Re-tested the error with Wk03 platform + wk03 UDA image and the error is
RANDOMLY REPRODUCIBLE ?

Please find my results below.

1. Vasco Device with attached widget: RANDOMLY REPRODUCIBLE
-----------------------------------------------------------

The error is REPRODUCIBLE RANDOMLY upon clicking multiple times on the text
label (1 out of 5 times), the label is highlighted (blue background is
displayed) only when we click on the area other than the text box. If a user
happens to click on the text box, vkb/qwert kep borad comes up.

HTML file + Qt Test Browser on device: REPRODUCIBLE
---------------------------------------------------

When tapped on the area of text label, blue backbround is displayed.

HTML file + Nokia default Browser on device: NOT REPRODUCIBLE
-------------------------------------------------------------

Launched the html file with the default browser and when tapped on the text
label, no highlight or no blue background is noticed.

HTML file + Qt Test Browser on Linux: REPRODUCIBLE
--------------------------------------------------

When clicking on the text label area with the mouse pointer (double click) the
whole text label is highlighted and blue background is displayed similar to the
screen shot.

HTML file + Safari Browser: REPRODUCIBLE
----------------------------------------

When clicking on the text label area with the mouse pointer (double click) the
whole text label is highlighted and blue background is displayed similar to the
screen shot.


Build Details:
--------------
Linux:    Webkit revision: r 75891

Safari Browser on windows: Version: 5.0.3 (7533.19.4)

Vasco device: Wk03 9.2 PS2 build with UDA Image

[reply] [-] Comment 9 Krishna 2011-02-03 22:08:04 EST

Please clone this error to webkit.org
Comment 1 Benjamin Poulain 2011-02-04 03:11:02 PST
Please follow http://trac.webkit.org/wiki/QtWebKitBugs when reporting bugs.

Please attach a reduction. In this case, a HTML file to reproduce the issue. I close as invalid, I will reopen the bug when all the information are there.
Comment 2 Prasad 2011-02-04 12:41:36 PST
Created attachment 81268 [details]
HTML file to reproduce the issue.
Comment 3 Prasad 2011-02-04 12:41:57 PST
Created attachment 81269 [details]
Screen shot -1
Comment 4 Prasad 2011-02-04 12:42:08 PST
Created attachment 81270 [details]
Screen shot -2
Comment 5 Benjamin Poulain 2011-02-04 15:11:21 PST
Wait a minute, isn't that the selection?
Comment 6 Benjamin Poulain 2011-02-04 15:12:47 PST

*** This bug has been marked as a duplicate of bug 38520 ***