Bug 52115 - Flaky Test: fast/events/tabindex-focus-blur-all.html
Summary: Flaky Test: fast/events/tabindex-focus-blur-all.html
Status: RESOLVED DUPLICATE of bug 58327
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other OS X 10.5
: P2 Normal
Assignee: WebKit Commit Bot
URL:
Keywords:
: 50155 (view as bug list)
Depends on:
Blocks: 50856
  Show dependency treegraph
 
Reported: 2011-01-08 15:54 PST by WebKit Commit Bot
Modified: 2011-05-09 07:54 PDT (History)
9 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description WebKit Commit Bot 2011-01-08 15:54:07 PST
This is an automatically generated bug from the commit-queue.
fast/events/tabindex-focus-blur-all.html has been flaky on the commit-queue.

fast/events/tabindex-focus-blur-all.html was authored by alice.liu@apple.com and pam@chromium.org.
http://trac.webkit.org/browser/trunk/LayoutTests/fast/events/tabindex-focus-blur-all.html

The commit-queue just saw fast/events/tabindex-focus-blur-all.html flake (Text diff mismatch) while processing attachment 78244 [details] on bug 52067.
Bot: eseidel-sf-cq  Port: Mac  Platform: Mac OS X 10.6.4

The bots will update this with information from each new failure.

If you believe this bug to be fixed or invalid, feel free to close.  The bots will re-open if the flake re-occurs.

If you would like to track this test fix with another bug, please close this bug as a duplicate.  The bots will follow the duplicate chain when making future comments.
Comment 1 Alice Liu 2011-01-10 10:40:20 PST
I don't quite understand the conditions that caused this automatic bug report to be filed, or what the expected next actions might be.  Could someone explain, perhaps eseidel? thank you.
Comment 2 Eric Seidel 2011-01-10 11:09:58 PST
The commit-queue saw fast/events/tabindex-focus-blur-all.html fail (with a text diff) when processing a patch, and then ran the tests a second time and it didn't fail.  Suggesting that fast/events/tabindex-focus-blur-all.html is flaky.

Unfortunately, since it failed to upload the actual diff, it's hard for us to understand how/why it failed. I have a patch up for review right now which should fix the diff-upload problem, so if this fails again the queue will update the patch with information about the new failure (including the -diffs.txt file from the results).

We can always close this bug if we believe it to be un-actionable (or dupe it against another bug about the same test?), and the commit-queue will re-open it (or update the dupe) if it sees it fail again.

Again, my apologies that the -diffs.txt upload failed, hopefully that issue will be resolved this afternoon and any future failures like this will contain the results diff (making it easier to understand the failure).
Comment 3 Eric Seidel 2011-01-10 11:23:07 PST
Btw, the diff-upload-failure bug is bug 52048.
Comment 4 Mihai Parparita 2011-02-03 13:42:25 PST
I don't know if this directly related, but I was able to get the test to consistently crash in debug builds when run in conjunction with another test:

run-webkit-tests fast/events/recorded-keydown-event.html fast/events/tabindex-focus-blur-all.html

FlateDecode: decoding error: incorrect data check.
ASSERTION FAILED: m_rootObject->isValid()
(/Users/mihaip/Developer/source/chromium1/src/third_party/WebKit/Source/WebCore/bridge/jsc/BridgeJSC.cpp:109 void JSC::Bindings::Instance::willDestroyRuntimeObject(JSC::Bindings::RuntimeObject*))
 -> JSC::Bindings::Instance::willDestroyRuntimeObject(JSC::Bindings::RuntimeObject*)
 -> JSC::Bindings::RuntimeObject::~RuntimeObject()
 -> WebKit::ProxyRuntimeObject::~ProxyRuntimeObject()
 -> JSC::MarkedSpace::allocate(unsigned long)
 -> JSC::Heap::allocate(unsigned long)
 -> JSC::JSCell::operator new(unsigned long, JSC::ExecState*)
 -> JSC::BooleanPrototype::BooleanPrototype(JSC::ExecState*, JSC::JSGlobalObject*, WTF::NonNullPassRefPtr<JSC::Structure>, JSC::Structure*)
 -> JSC::JSGlobalObject::reset(JSC::JSValue)
 -> JSC::JSGlobalObject::init(JSC::JSObject*)
 -> JSC::JSGlobalObject::JSGlobalObject(WTF::NonNullPassRefPtr<JSC::Structure>, JSC::JSGlobalObject::JSGlobalObjectData*, JSC::JSObject*)
 -> WebCore::JSDOMGlobalObject::JSDOMGlobalObject(WTF::NonNullPassRefPtr<JSC::Structure>, WebCore::JSDOMGlobalObject::JSDOMGlobalObjectData*, JSC::JSObject*)
 -> WebCore::JSDOMWindowBase::JSDOMWindowBase(WTF::NonNullPassRefPtr<JSC::Structure>, WTF::PassRefPtr<WebCore::DOMWindow>, WebCore::JSDOMWindowShell*)
 -> WebCore::JSDOMWindow::JSDOMWindow(WTF::NonNullPassRefPtr<JSC::Structure>, WTF::PassRefPtr<WebCore::DOMWindow>, WebCore::JSDOMWindowShell*)
 -> WebCore::JSDOMWindowShell::setWindow(WTF::PassRefPtr<WebCore::DOMWindow>)
 -> WebCore::ScriptController::clearWindowShell(bool)
 -> WebCore::Frame::pageDestroyed()
 -> WebCore::FrameLoader::closeAndRemoveChild(WebCore::Frame*)
 -> WebCore::FrameLoader::detachFromParent()
 -> WebCore::FrameLoader::detachChildren()
 -> WebCore::FrameLoader::detachFromParent()
 -> WebCore::FrameLoader::frameDetached()
 -> WebCore::HTMLFrameOwnerElement::willRemove()
 -> WebCore::HTMLFrameElementBase::willRemove()
 -> WebCore::ContainerNode::willRemove()
 -> WebCore::ContainerNode::willRemove()
 -> WebCore::willRemoveChildren(WebCore::ContainerNode*)
 -> WebCore::ContainerNode::removeChildren()
 -> WebCore::Document::implicitOpen()
 -> WebCore::Document::open(WebCore::Document*)
 -> WebCore::Document::write(WebCore::SegmentedString const&, WebCore::Document*)
 -> WebCore::documentWrite(JSC::ExecState*, WebCore::HTMLDocument*, WebCore::NewlineRequirement)
Comment 5 Mihai Parparita 2011-02-03 14:38:26 PST
(In reply to comment #4)
> I don't know if this directly related, but I was able to get the test to consistently crash in debug builds when run in conjunction with another test:
> 
> run-webkit-tests fast/events/recorded-keydown-event.html fast/events/tabindex-focus-blur-all.html

I ended up filing bug 53716 about this (since it's probably not related to the flakyness).
Comment 6 Csaba Osztrogonác 2011-04-08 00:17:54 PDT
*** Bug 50155 has been marked as a duplicate of this bug. ***
Comment 8 Laszlo Gombos 2011-05-08 23:16:17 PDT

*** This bug has been marked as a duplicate of bug 58327 ***
Comment 9 Ademar Reis 2011-05-09 07:54:21 PDT
Revision r83265 cherry-picked into qtwebkit-2.1.x with commit 6b42f67 <http://gitorious.org/webkit/qtwebkit/commit/6b42f67>