Bug 51499 - Search input magnifier icon should be moved and mirrored for RTL
Summary: Search input magnifier icon should be moved and mirrored for RTL
Status: RESOLVED DUPLICATE of bug 158007
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 64108
  Show dependency treegraph
 
Reported: 2010-12-22 14:54 PST by Evan Stade
Modified: 2016-08-07 20:44 PDT (History)
9 users (show)

See Also:


Attachments
o2 cookies from mail need fast (9.09 KB, text/css)
2013-06-17 17:49 PDT, Jimi
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Evan Stade 2010-12-22 14:54:51 PST
The following snippet will give a search input where the text is input RTL:

<input type=search results=5 style="direction: rtl;">

however, the icons still show in the LTR locations, ie., the search glass is on the left and the x is on the right. They should be swapped (also the search glass should be horizontally mirrored).
Comment 1 Jeremy Moskovich 2011-07-17 05:05:15 PDT
On OS X the native search field always has the magnifier icon on the left, regardless of the control directionality. 

Mitz/Dave: Does the Mac port wish to preserve the OS native behavior or are you ok having the icons flipped for rtl on for the Apple ports?
Comment 2 mitz 2011-07-18 09:58:29 PDT
Please don’t change this in Mac OS X.
Comment 3 Dan Beam 2012-11-26 16:01:52 PST
So what's the status of this bug?  Is it WontFix or simply not applicable on Mac?  We hit this issue again today here - http://code.google.com/p/chromium/issues/detail?id=162744
Comment 4 Eric Seidel 2012-11-26 16:19:15 PST
I suspect we don't want to diverge behavior from Mac on Mac.  So this is just a fix for other ports then.  There are numerous platform-specific form-control/editing behaviors, I guess this is just another one.
Comment 5 Jimi 2013-06-17 17:49:09 PDT
Created attachment 204871 [details]
o2 cookies from mail need fast

o2 cookies from mail need fast
Comment 6 Aharon (Vladimir) Lanin 2013-06-18 01:08:09 PDT
Sounds like this should get moved to crbug.
Comment 7 Jeremy Moskovich 2013-06-18 01:14:50 PDT
Chromium bug is crbug.com/67848, I'm leaving this bug open in case ports other than the Mac port wish to modify the behavior.
Comment 8 Kent Tamura 2016-08-07 20:44:08 PDT

*** This bug has been marked as a duplicate of bug 158007 ***