Bug 49922 - Simplify make-hash-tools.pl
Summary: Simplify make-hash-tools.pl
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Patrick R. Gansterer
URL:
Keywords:
Depends on:
Blocks: 49925 49926
  Show dependency treegraph
 
Reported: 2010-11-22 10:15 PST by Patrick R. Gansterer
Modified: 2010-12-29 14:59 PST (History)
6 users (show)

See Also:


Attachments
Patch (7.75 KB, patch)
2010-11-22 11:16 PST, Patrick R. Gansterer
no flags Details | Formatted Diff | Diff
Patch (7.24 KB, patch)
2010-11-23 05:16 PST, Patrick R. Gansterer
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick R. Gansterer 2010-11-22 10:15:40 PST
see patch
Comment 1 Patrick R. Gansterer 2010-11-22 11:16:39 PST
Created attachment 74576 [details]
Patch
Comment 2 WebKit Review Bot 2010-11-22 11:18:12 PST
Attachment 74576 [details] did not pass style-queue:

Failed to run "['WebKitTools/Scripts/check-webkit-style', '--diff-files', u'WebCore/ChangeLog', u'WebCore/html/DocTypeStrings.gperf', u'WebCore/make-hash-tools.pl', u'WebCore/platform/ColorData.gperf', u'WebCore/platform/HashTools.h']" exit_code: 1
WebCore/platform/HashTools.h:38:  mode_if_no_sysid is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebCore/platform/HashTools.h:39:  mode_if_sysid is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebCore/platform/HashTools.h:64:  Could not find a newline character at the end of the file.  [whitespace/ending_newline] [5]
Total errors found: 3 in 5 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Eric Seidel (no email) 2010-11-22 13:09:50 PST
Attachment 74576 [details] did not build on chromium:
Build output: http://queues.webkit.org/results/6347002
Comment 4 Andras Becsi 2010-11-23 04:55:28 PST
Comment on attachment 74576 [details]
Patch

LGTM on the whole, just a few notes.

View in context: https://bugs.webkit.org/attachment.cgi?id=74576&action=review

Please do not change the license of HashTools.h file since you move the code from make-hash-tools.pl.

> WebCore/platform/HashTools.h:65
>  \ No newline at end of file

The chromium build should be fixed by adding the missing newline here.
Comment 5 Patrick R. Gansterer 2010-11-23 04:58:00 PST
(In reply to comment #4)
> (From update of attachment 74576 [details])
> Please do not change the license of HashTools.h file since you move the code from make-hash-tools.pl.
The problem is, that HashTools.h has no license :-(. If you give me a better one i would be happy to change it.

> > WebCore/platform/HashTools.h:65
> >  \ No newline at end of file
> 
> The chromium build should be fixed by adding the missing newline here.
I saw it too late for r?, but will change it before commit.
Comment 6 Andras Becsi 2010-11-23 05:04:36 PST
(In reply to comment #5)
> (In reply to comment #4)
> > (From update of attachment 74576 [details] [details])
> > Please do not change the license of HashTools.h file since you move the code from make-hash-tools.pl.
> The problem is, that HashTools.h has no license :-(. If you give me a better one i would be happy to change it.

I see, the generated HashTools.h has no license, but the code you moved was in make-hash-tools.pl, which has LGPL license.
Comment 7 Patrick R. Gansterer 2010-11-23 05:16:27 PST
Created attachment 74649 [details]
Patch

(In reply to comment #6)
> (In reply to comment #5)
> > (In reply to comment #4)
> > > (From update of attachment 74576 [details] [details] [details])
> > > Please do not change the license of HashTools.h file since you move the code from make-hash-tools.pl.
> > The problem is, that HashTools.h has no license :-(. If you give me a better one i would be happy to change it.
> 
> I see, the generated HashTools.h has no license, but the code you moved was in make-hash-tools.pl, which has LGPL license.
Uuups, missed that. Sorry!
Comment 8 WebKit Review Bot 2010-11-23 05:18:39 PST
Attachment 74649 [details] did not pass style-queue:

Failed to run "['WebKitTools/Scripts/check-webkit-style', '--diff-files', u'WebCore/ChangeLog', u'WebCore/html/DocTypeStrings.gperf', u'WebCore/make-hash-tools.pl', u'WebCore/platform/ColorData.gperf', u'WebCore/platform/HashTools.h']" exit_code: 1
WebCore/platform/HashTools.h:33:  mode_if_no_sysid is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebCore/platform/HashTools.h:34:  mode_if_sysid is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Total errors found: 2 in 5 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 9 WebKit Commit Bot 2010-11-24 05:25:51 PST
The commit-queue encountered the following flaky tests while processing attachment 74649 [details]:

fast/profiler/throw-exception-from-eval.html

Please file bugs against the tests.  These tests were authored by kmccullough@apple.com, oliver@apple.com, and timothy@apple.com.  The commit-queue is continuing to process your patch.
Comment 10 WebKit Commit Bot 2010-11-24 05:27:17 PST
Comment on attachment 74649 [details]
Patch

Clearing flags on attachment: 74649

Committed r72664: <http://trac.webkit.org/changeset/72664>
Comment 11 WebKit Commit Bot 2010-11-24 05:27:23 PST
All reviewed patches have been landed.  Closing bug.
Comment 12 Eric Seidel (no email) 2010-12-29 14:50:29 PST
This change causes HashTools to no longer be tracked for dependency changes.  The Xcode project, for example, is missing HashTools.h.

I encountered this because my laptop hadn't built in a long time and had an old copy of HashTools.h in the DerivedSources folder (which for whatever reason didn't seem to be cleared on a clean build?).

Eventually I found and deleted that HashTools.h and my build worked, but it would have worked sooner if the build systems had been educated about the new location of HashTools.h. :)
Comment 13 Eric Seidel (no email) 2010-12-29 14:59:16 PST
Committed r74764: <http://trac.webkit.org/changeset/74764>