Bug 49398 - Spatial Navigation: Need better way to control size of content in tests.
: Spatial Navigation: Need better way to control size of content in tests.
Status: RESOLVED FIXED
: WebKit
Accessibility
: 528+ (Nightly build)
: PC Mac OS X 10.5
: P2 Normal
Assigned To:
:
:
:
: 49382
  Show dependency treegraph
 
Reported: 2010-11-11 12:01 PST by
Modified: 2010-11-15 16:26 PST (History)


Attachments
Patch (1.38 KB, patch)
2010-11-11 13:09 PST, Yael
tonikitoo: review-
Review Patch | Details | Formatted Diff | Diff
Patch (4.46 KB, patch)
2010-11-12 06:30 PST, Yael
no flags Review Patch | Details | Formatted Diff | Diff
Patch (5.14 KB, patch)
2010-11-12 07:20 PST, Yael
no flags Review Patch | Details | Formatted Diff | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2010-11-11 12:01:30 PST
Due to font size differences between the ports, we need something other than text to determine the size of divs and iframes in Spatial Navigation tests.

I am about to submit a patch with a simple image, it will be used in future patches for the tests.
------- Comment #1 From 2010-11-11 12:07:52 PST -------
It looks like a duplicated bug.

Please see bug 47448, bug 47449 and 43030
------- Comment #2 From 2010-11-11 13:09:20 PST -------
Created an attachment (id=73642) [details]
Patch
------- Comment #3 From 2010-11-11 13:19:22 PST -------
(In reply to comment #1)
> It looks like a duplicated bug.
> 
> Please see bug 47448, bug 47449 and 43030

There is a good chance that you are right.
Once we have the image committed, I will change the tests to use it and see if it solves the other bugs. (If yes, then the patch at https://bugs.webkit.org/show_bug.cgi?id=49382 can become much smaller).
------- Comment #4 From 2010-11-11 14:44:53 PST -------
https://bugs.webkit.org/show_bug.cgi?id=47449 does not seem related to this.
Pressing the end key should take you to the bottom of the page regardless of the size of that page.

https://bugs.webkit.org/show_bug.cgi?id=47448 might be related, need to investigate more.

https://bugs.webkit.org/show_bug.cgi?id=43030 should be fixed once we switch the multiple <br> into a fixed size image.
------- Comment #5 From 2010-11-11 20:52:44 PST -------
(From update of attachment 73642 [details])
Yael, I understand your logic, and I like it.

Please provide the patch that changes the tests together with this image. There is no reason to commit this png alone.
------- Comment #6 From 2010-11-12 05:15:07 PST -------
(In reply to comment #5)
> (From update of attachment 73642 [details] [details])
> Yael, I understand your logic, and I like it.
> 
> Please provide the patch that changes the tests together with this image. There is no reason to commit this png alone.

Thanks for the review Antonio. From analysis I did last night, the only existing bug that I can fix by replacing the test content with an image is https://bugs.webkit.org/show_bug.cgi?id=43030.
I will fix that and re-submit.
------- Comment #7 From 2010-11-12 06:30:42 PST -------
Created an attachment (id=73732) [details]
Patch

This patch adds the green image and also modifies fast/events/spatial-navigation/snav-clipped-overflowed-content.html to use it.
I am still building for gtk and mac, and will set review flag once I  verify that it works on those platforms.
------- Comment #8 From 2010-11-12 07:20:10 PST -------
Created an attachment (id=73742) [details]
Patch

Tested on qt, gtk and mac. They all pass with this updated test.
------- Comment #9 From 2010-11-12 07:22:56 PST -------
*** Bug 43030 has been marked as a duplicate of this bug. ***
------- Comment #10 From 2010-11-12 08:36:38 PST -------
(From update of attachment 73742 [details])
Clearing flags on attachment: 73742

Committed r71915: <http://trac.webkit.org/changeset/71915>
------- Comment #11 From 2010-11-12 08:36:44 PST -------
All reviewed patches have been landed.  Closing bug.
------- Comment #12 From 2010-11-15 16:26:26 PST -------
Revision r71915 cherry-picked into qtwebkit-2.1 with commit 655d83e <http://gitorious.org/webkit/qtwebkit/commit/655d83e>