Bug 48927 - Some links do not work on WebKit GTK+, and other links are displayed on top of the failed links.
Summary: Some links do not work on WebKit GTK+, and other links are displayed on top o...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other Linux
: P2 Major
Assignee: Nobody
URL: http://www.nba.com
Keywords:
: 51251 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-11-03 10:11 PDT by Ronald Clifford Buckman
Modified: 2011-04-07 15:49 PDT (History)
2 users (show)

See Also:


Attachments
nba.com on WebKitGTK+ 1.2.5 (354.36 KB, image/png)
2010-11-03 10:11 PDT, Ronald Clifford Buckman
no flags Details
nba.com in Konqueror on Qt Webkit 4.7 (647.66 KB, image/png)
2010-11-22 11:42 PST, Ronald Clifford Buckman
no flags Details
nba.com in rekonq and Arora on Qt WebKit 4.7 (850.81 KB, image/png)
2010-12-13 15:02 PST, Ronald Clifford Buckman
no flags Details
nba.com in rekonq and Konqueror-KHTML, (843.53 KB, image/png)
2010-12-13 15:10 PST, Ronald Clifford Buckman
no flags Details
nba.com on WebKitGTK+ 1.3.10 with patch applied. (643.71 KB, image/png)
2011-02-16 19:34 PST, Ronald Clifford Buckman
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ronald Clifford Buckman 2010-11-03 10:11:05 PDT
Created attachment 72834 [details]
nba.com on WebKitGTK+ 1.2.5

The links on the linkbar which has "NEWS, SCORES & SCHEDULES, VIDEO, ..." do not click in WebKit GTK+ 1.2.5.  Text links display over the linkbar.  W3.org validator did report 204 errors on the home page on November 3, 2010.
Comment 1 Ronald Clifford Buckman 2010-11-22 11:42:20 PST
Created attachment 74579 [details]
nba.com in Konqueror on Qt Webkit 4.7

The same display problem is in KHTML.  Likely due to HTML errors on the web page.
Comment 2 Ronald Clifford Buckman 2010-12-13 15:02:32 PST
Created attachment 76447 [details]
nba.com in rekonq and Arora on Qt WebKit 4.7

The bug is seen in Konqueror-WebKit and Rekonq, but not in Arora even though they all use the same layout engine.
Comment 3 Ronald Clifford Buckman 2010-12-13 15:10:03 PST
Created attachment 76449 [details]
nba.com in rekonq and Konqueror-KHTML,

This bug shows up in rekonq on Qt WebKit 4.7.  It no longer show on KHTML in Konqueror 4.5.  Also, the NBA score applet is not shown in rekonq or other Qt WebKit 4.7 browsers due to bug 50533.
Comment 4 Martin Robinson 2010-12-17 09:30:46 PST
*** Bug 51251 has been marked as a duplicate of this bug. ***
Comment 5 Martin Robinson 2010-12-18 18:37:49 PST
The issue here seems to the label element next to the search box and button. The label appears to exist only for accessibility and has has visilbity:hidden and font-size:0. WebKitGTK+ sets the default font size to 5 points by default, which is enough to bump the other text over. This doesn't break in Safari and Chrome, because Safari uses a smaller minimum font size and Chromium doesn't have one (as far as I know).
Comment 6 Ronald Clifford Buckman 2010-12-28 11:01:02 PST
The WebKit version that I am using on Qt 4.7 is numbered Qt WebKit 2.0.  It is included in Kubuntu 10.10.
Comment 7 Ronald Clifford Buckman 2011-02-08 20:49:10 PST
I confirmed this bug in both dwb and Uzbl running WebKitGTK+ 1.3.10.
Comment 8 Martin Robinson 2011-02-08 22:36:40 PST
(In reply to comment #7)
> I confirmed this bug in both dwb and Uzbl running WebKitGTK+ 1.3.10.

Try this uzbl config:

set font_size = 10
set minimum_font_size = 1

I believe that the issue in WebKitGTK+ is that the minimum font size is set to high by default.
Comment 9 Ronald Clifford Buckman 2011-02-15 00:44:13 PST
I set the minimum font size in the config file in uzbl to 1 and the font size to 10 and the blue links are still displayed on top of the menu bar like before.  The same display problem is now in Firefox 3.6 and SeaMonkey 2.0, although Arora running Qt WebKit 2.0 still displays the page as intended with the pull down menu working.
Comment 10 Martin Robinson 2011-02-16 10:20:47 PST
(In reply to comment #9)
> I set the minimum font size in the config file in uzbl to 1 and the font size to 10 and the blue links are still displayed on top of the menu bar like before.  The same display problem is now in Firefox 3.6 and SeaMonkey 2.0, although Arora running Qt WebKit 2.0 still displays the page as intended with the pull down menu working.

Are you building 1.3.10 from source? Can you try applying this patch and then running the GtkLauncher? After doing that and loading http://www.nba.com, the links show in the correct place.

diff --git a/Tools/GtkLauncher/main.c b/Tools/GtkLauncher/main.c
index ad666e2..d9f49aa 100644
--- a/Tools/GtkLauncher/main.c
+++ b/Tools/GtkLauncher/main.c
@@ -200,6 +200,10 @@ static GtkWidget* createWindow(WebKitWebView** outWebView)
     gtk_widget_set_name(window, "GtkLauncher");
 
     webView = WEBKIT_WEB_VIEW(webkit_web_view_new());
+    WebKitWebSettings* settings = webkit_web_view_get_settings(webView);
+    g_object_set(settings, "minimum-font-size", 1, NULL);
+    webkit_web_view_set_settings(webView, settings);
+
     uriEntry = gtk_entry_new();
 
     vbox = gtk_vbox_new(FALSE, 0);
Comment 11 Ronald Clifford Buckman 2011-02-16 19:34:33 PST
Created attachment 82740 [details]
nba.com on WebKitGTK+ 1.3.10 with patch applied.

Still a display problem.  Combination of poor coding on the home page and WebKitGTK (as well as Gecko on LInux and the KDE's Kwebkit component) not correcting it.
Comment 12 Martin Robinson 2011-02-17 09:13:41 PST
(In reply to comment #11)
> Created an attachment (id=82740) [details]
> nba.com on WebKitGTK+ 1.3.10 with patch applied.
> 
> Still a display problem.  Combination of poor coding on the home page and WebKitGTK (as well as Gecko on LInux and the KDE's Kwebkit component) not correcting it.

This is high confusing. Lowering the minimum font size fixes the issue for me. I see no other reason why this would break. What version of GTK+ are you using? What GTK+ theme?
Comment 13 Martin Robinson 2011-02-17 15:02:10 PST
(In reply to comment #11)
> Created an attachment (id=82740) [details]
> nba.com on WebKitGTK+ 1.3.10 with patch applied.
> 
> Still a display problem.  Combination of poor coding on the home page and WebKitGTK (as well as Gecko on LInux and the KDE's Kwebkit component) not correcting it.

Do you mind trying one more thing? Please drop the minimum font size down to 0 (with the patch I previously pasted for GtkLauncher) and see if that improves things.
Comment 14 Sergio Villar Senin 2011-02-18 02:33:45 PST
(In reply to comment #13)
> (In reply to comment #11)
> > Created an attachment (id=82740) [details] [details]
> > nba.com on WebKitGTK+ 1.3.10 with patch applied.
> > 
> > Still a display problem.  Combination of poor coding on the home page and WebKitGTK (as well as Gecko on LInux and the KDE's Kwebkit component) not correcting it.
> 
> Do you mind trying one more thing? Please drop the minimum font size down to 0 (with the patch I previously pasted for GtkLauncher) and see if that improves things.

Martin it works fine for me with your patch (font size to 0). If the minimum font size is 1 then the problem is still there (that's why it's always reproducible in epy as it isn't possible to drop the minimum value bellow 1).
Comment 15 Martin Robinson 2011-02-18 08:36:02 PST
Here's my proposal then:

1. Epiphany should allow minimum-font-size values of 1 from the preferences dialog and that should be the default. Maybe it should even hide the option now that you can adjust the default font size, which is a more appropriate knob.
2. We should make sure that minimum-logical-font-size can also be set to 0 and that they are both zero by default.
Comment 16 Sergio Villar Senin 2011-02-21 00:39:22 PST
(In reply to comment #15)
> Here's my proposal then:
> 
> 1. Epiphany should allow minimum-font-size values of 1 from the preferences dialog and that should be the default. Maybe it should even hide the option now that you can adjust the default font size, which is a more appropriate knob.

I agree. Chrome does not expose that setting, and in Firefox is an "advanced setting" default to 0.

> 2. We should make sure that minimum-logical-font-size can also be set to 0 and that they are both zero by default.

Againg agree
Comment 17 Ronald Clifford Buckman 2011-02-22 23:48:41 PST
I compiled and installed WebKitGTK+ 1.3.11, moved the minimum font size to 0 on dwb and the page displays as intended.  I confirm that any minimum font size above 0, causes the display and menu problem.
Comment 18 Sergio Villar Senin 2011-04-07 12:36:46 PDT
I think this one was fixed, Martin?
Comment 19 Martin Robinson 2011-04-07 15:49:38 PDT
Yep. Closing.