Bug 48414 - Warning when compiling the chromium port of DumpRenderShell with clang
Summary: Warning when compiling the chromium port of DumpRenderShell with clang
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P5 Trivial
Assignee: Nobody
URL:
Keywords:
: 48851 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-10-27 04:49 PDT by Søren Gjesse
Modified: 2010-11-02 14:38 PDT (History)
3 users (show)

See Also:


Attachments
Simple patch (1.55 KB, patch)
2010-10-27 04:49 PDT, Søren Gjesse
no flags Details | Formatted Diff | Diff
Patch (1.63 KB, patch)
2010-10-29 02:38 PDT, Søren Gjesse
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Søren Gjesse 2010-10-27 04:49:44 PDT
Created attachment 72010 [details]
Simple patch

Method javaScriptFlagsForLoad in TestShell.h compares a size_t argument >= 0 which causes a warning in clang
Comment 1 Hans Wennborg 2010-10-27 07:08:23 PDT
Looks good to me, but I am not a reviewer.
Comment 2 Hans Wennborg 2010-10-27 07:11:15 PDT
Looking closer, shouldn't the ChangeLog contain a link to this bug entry? I thought the tools put that in automatically...
Comment 3 Søren Gjesse 2010-10-29 02:38:08 PDT
Created attachment 72304 [details]
Patch
Comment 4 Andreas Kling 2010-10-29 06:35:00 PDT
Comment on attachment 72304 [details]
Patch

r=me
Comment 5 WebKit Commit Bot 2010-11-01 08:49:44 PDT
The commit-queue encountered the following flaky tests while processing attachment 72304 [details]:

http/tests/cache/subresource-expiration.html

Please file bugs against the tests.  These tests were authored by koivisto@iki.fi.  The commit-queue is continuing to process your patch.
Comment 6 WebKit Commit Bot 2010-11-01 08:50:29 PDT
Comment on attachment 72304 [details]
Patch

Clearing flags on attachment: 72304

Committed r71030: <http://trac.webkit.org/changeset/71030>
Comment 7 WebKit Commit Bot 2010-11-01 08:50:34 PDT
All reviewed patches have been landed.  Closing bug.
Comment 8 Cosmin Truta 2010-11-02 14:38:57 PDT
*** Bug 48851 has been marked as a duplicate of this bug. ***