Bug 46620 - drag a picture from a webpage onto the desktop and finder hangs and webkit may crash
Summary: drag a picture from a webpage onto the desktop and finder hangs and webkit ma...
Status: RESOLVED DUPLICATE of bug 46380
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-27 07:06 PDT by Steven Kolins
Modified: 2010-09-27 10:36 PDT (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steven Kolins 2010-09-27 07:06:30 PDT
I happened to drag the Sojourner Truth picture from here <http://joyefulthings.blogspot.com/2007_01_01_archive.html> but also tried a few others. Kept hanging the finder and crashing webkit most of the time. On relaunch of the finder most of the time the picture appeared on the desktop.

Attached are wbekit crash and here's a snippet from the system log: 

Sep 27 09:40:18 com.apple.launchd.peruser.502[190] ([0x0-0x5ae5ae].org.webkit.nightly.WebKit[50731]): Job appears to have crashed: Segmentation fault
Sep 27 09:40:18 com.apple.coreservicesd[61]: NOTE:  Using non-mach-based version of client -> server communication, via direct function calls.
Sep 27 09:40:18: --- last message repeated 1 time ---
Sep 27 09:40:18 ReportCrash[5677]: Saved crash report for Safari[50731] version r68242 (68242) to /Users/smkolins/Library/Logs/DiagnosticReports/Safari_2010-09-27-094018_AALADM38.crash
Sep 27 09:40:47 com.apple.launchd.peruser.502[190] (com.apple.Finder[214]): Exited: Terminated
Sep 27 09:40:51 Safari[5968]: WebKit failed to shut down cleanly.  Checking for Safari extensions.
Sep 27 09:40:51 Safari[5968]: WebKit r68242 initialized.
Sep 27 09:40:51 com.apple.coreservicesd[61]: NOTE:  Using non-mach-based version of client -> server communication, via direct function calls.
Sep 27 09:40:54: --- last message repeated 3 times ---
Comment 1 Steven Kolins 2010-09-27 07:07:07 PDT
Safari 5.02 doesn't crash or cause Finder problems doing the same thing.
Comment 2 Alexey Proskuryakov 2010-09-27 10:36:43 PDT
This should be fixed in the next nightly build.

*** This bug has been marked as a duplicate of bug 46380 ***