Bug 46327 - [Qt] box-shadow does not blur (is solid) when using border-radius
Summary: [Qt] box-shadow does not blur (is solid) when using border-radius
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Helder Correia
URL:
Keywords: Qt, QtTriaged
: 29563 (view as bug list)
Depends on: 48223
Blocks: 34479
  Show dependency treegraph
 
Reported: 2010-09-22 17:54 PDT by Helder Correia
Modified: 2010-11-20 19:14 PST (History)
4 users (show)

See Also:


Attachments
Showing difference between Chrome/Safari and QtTestBrowser (103.97 KB, image/png)
2010-09-22 17:54 PDT, Helder Correia
no flags Details
Test case (194 bytes, text/html)
2010-09-22 17:56 PDT, Helder Correia
no flags Details
Patch (1.96 KB, patch)
2010-11-01 16:44 PDT, Helder Correia
no flags Details | Formatted Diff | Diff
Patch 2 (2.28 KB, patch)
2010-11-01 22:45 PDT, Helder Correia
no flags Details | Formatted Diff | Diff
Include updated basic-shadows test. (55.04 KB, patch)
2010-11-05 16:50 PDT, Helder Correia
kling: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Helder Correia 2010-09-22 17:54:33 PDT
Created attachment 68482 [details]
Showing difference between Chrome/Safari and QtTestBrowser

Attached a picture showing the issue.  Test case:

<!DOCTYPE html>
<html>
<style type="text/css">
div {
  box-shadow: 2px 2px 6px rgba(200,0,0,0.6);
  border-radius: 95px 95px;                                                                                                                                                                                   
  padding-top: 95px;
}
</style>
<body><div/></body>
</html>

See also: 36939, 29563
Comment 1 Helder Correia 2010-09-22 17:56:42 PDT
Created attachment 68483 [details]
Test case
Comment 2 Helder Correia 2010-11-01 16:44:19 PDT
Created attachment 72597 [details]
Patch
Comment 3 Helder Correia 2010-11-01 16:45:39 PDT
Added proposed patch for feedback.  Please note that a test is missing, I'll take care of that.
Comment 4 Helder Correia 2010-11-01 22:45:34 PDT
Created attachment 72630 [details]
Patch 2

Optimize when not blurring.
Comment 5 Ariya Hidayat 2010-11-05 10:12:18 PDT
Please attach test case (or test baseline).
Comment 6 Helder Correia 2010-11-05 16:50:15 PDT
Created attachment 73140 [details]
Include updated basic-shadows test.
Comment 7 Andreas Kling 2010-11-07 17:29:38 PST
Comment on attachment 73140 [details]
Include updated basic-shadows test.

r=me
Comment 8 Ariya Hidayat 2010-11-07 17:44:22 PST
Comment on attachment 73140 [details]
Include updated basic-shadows test.

Let me block cq, since it depends on 48223
Comment 9 Andreas Kling 2010-11-07 18:55:04 PST
Committed r71488: <http://trac.webkit.org/changeset/71488>
Comment 10 Antonio Gomes 2010-11-08 10:39:25 PST
*** Bug 29563 has been marked as a duplicate of this bug. ***