Bug 4628 - Use ICU instead of Carbon in khtml::isBreakable()
Summary: Use ICU instead of Carbon in khtml::isBreakable()
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Enhancement
Assignee: mitz
URL:
Keywords:
: 12175 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-08-24 22:42 PDT by mitz
Modified: 2008-02-01 10:11 PST (History)
3 users (show)

See Also:


Attachments
thai line breaking test (28.39 KB, text/html)
2007-01-09 06:21 PST, Darin Adler
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description mitz 2005-08-24 22:42:49 PDT
Investigate ways to switch to ICU for finding line breaks instead of using Carbon, as Darin has suggested 
in http://bugzilla.opendarwin.org/show_bug.cgi?id=3963#c10 .
Comment 1 Darin Adler 2007-01-09 05:43:20 PST
*** Bug 12175 has been marked as a duplicate of this bug. ***
Comment 2 Darin Adler 2007-01-09 06:21:37 PST
Created attachment 12331 [details]
thai line breaking test
Comment 3 Darin Adler 2007-01-09 06:47:19 PST
The tree now has ICU in addition to Carbon. But we still use Carbon because of Thai line breaking. NOt sure when we should close this.
Comment 4 mitz 2008-02-01 10:11:21 PST
(In reply to comment #3)
> The tree now has ICU in addition to Carbon. But we still use Carbon because of
> Thai line breaking. NOt sure when we should close this.

I think now that <http://trac.webkit.org/projects/webkit/changeset/29915> has landed it is time to close this bug.