Bug 12175 - port break_lines.cpp to be platform independent
Summary: port break_lines.cpp to be platform independent
Status: RESOLVED DUPLICATE of bug 4628
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Darin Adler
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-01-08 22:03 PST by Darin Adler
Modified: 2007-01-09 05:43 PST (History)
1 user (show)

See Also:


Attachments
patch, including change log -- passes all layout tests (11.31 KB, patch)
2007-01-08 22:07 PST, Darin Adler
hyatt: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Darin Adler 2007-01-08 22:03:55 PST
Hyatt asked me to port break_lines.cpp to "use ICU", but it can be ported to use TextBreakIterator.h and hence be more-or-less platform independent.
Comment 1 Darin Adler 2007-01-08 22:07:00 PST
Created attachment 12324 [details]
patch, including change log -- passes all layout tests
Comment 2 Dave Hyatt 2007-01-08 22:33:05 PST
Comment on attachment 12324 [details]
patch, including change log -- passes all layout tests

r=me.  Run tests!
Comment 3 mitz 2007-01-08 23:04:45 PST
Be sure to test Thai word breaks! See <http://www.opensource.apple.com/darwinsource/10.4.8.ppc/ICU-6.2.9/icuSources/test/thaitest/> for possible test data.
Comment 4 Darin Adler 2007-01-09 05:43:20 PST

*** This bug has been marked as a duplicate of 4628 ***