Bug 43605 - REGRESSION (r64712): YouTube video pages have contents of <noembed> elements overlapping the video description
Summary: REGRESSION (r64712): YouTube video pages have contents of <noembed> elements ...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P1 Normal
Assignee: Nobody
URL: http://www.youtube.com/watch?v=z2nQZP...
Keywords: Regression
Depends on:
Blocks: 41115
  Show dependency treegraph
 
Reported: 2010-08-05 21:00 PDT by Mark Rowe (bdash)
Modified: 2010-08-06 18:56 PDT (History)
3 users (show)

See Also:


Attachments
Patch (4.33 KB, patch)
2010-08-05 23:54 PDT, Adam Barth
no flags Details | Formatted Diff | Diff
Patch (4.29 KB, patch)
2010-08-05 23:57 PDT, Adam Barth
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Rowe (bdash) 2010-08-05 21:00:37 PDT
After r64712 YouTube video pages, such as the one at <http://www.youtube.com/watch?v=z2nQZPC2uTs>, have some white text visible on top of the video description area.  The web inspector shows that the visible text appears to be the contents of a <noembed> element that is present in the page.
Comment 1 Adam Barth 2010-08-05 21:03:31 PDT
Crazy.  Investigating.
Comment 2 Adam Barth 2010-08-05 22:25:35 PDT
We're correctly swallowing the contents as text, but we're rendering it when we shouldn't be.  We need to teach the noembed element to not render itself.
Comment 3 Adam Barth 2010-08-05 23:05:47 PDT
Building a possible patch now.
Comment 4 Adam Barth 2010-08-05 23:54:32 PDT
Created attachment 63700 [details]
Patch
Comment 5 Adam Barth 2010-08-05 23:57:01 PDT
Created attachment 63701 [details]
Patch
Comment 6 Adam Barth 2010-08-05 23:57:33 PDT
I verified that we're handling nolayer correctly.
Comment 7 Adam Barth 2010-08-06 00:13:06 PDT
See also https://bugs.webkit.org/show_bug.cgi?id=43611
Comment 8 Eric Seidel (no email) 2010-08-06 13:17:04 PDT
Comment on attachment 63701 [details]
Patch

OK.  Why wouldn't this be part of HTMLEmbedElement:: rendererIsNeeded instead?
Comment 9 Adam Barth 2010-08-06 14:38:41 PDT
> OK.  Why wouldn't this be part of HTMLEmbedElement:: rendererIsNeeded instead?

Because it's the noembed element :)

(There is no HTMLNoembedElement.)
Comment 10 Adam Barth 2010-08-06 18:56:19 PDT
Comment on attachment 63701 [details]
Patch

Clearing flags on attachment: 63701

Committed r64890: <http://trac.webkit.org/changeset/64890>
Comment 11 Adam Barth 2010-08-06 18:56:25 PDT
All reviewed patches have been landed.  Closing bug.