Bug 43568 - [GTK] Some sputnik tests fail
Summary: [GTK] Some sputnik tests fail
Status: RESOLVED DUPLICATE of bug 88519
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P2 Normal
Assignee: Nobody
URL:
Keywords: Gtk, LayoutTestFailure
Depends on:
Blocks:
 
Reported: 2010-08-05 11:59 PDT by Martin Robinson
Modified: 2013-04-23 06:26 PDT (History)
6 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Robinson 2010-08-05 11:59:03 PDT
A few of the sputnik tests fail:

fast/js/sputnik/Conformance/15_Native_Objects/15.4_Array/15.4.4/15.4.4.12_Array_prototype_splice/S15.4.4.12_A2.1_T3.html	
fast/js/sputnik/Conformance/15_Native_Objects/15.8_Math/15.8.2/15.8.2.16_sin/S15.8.2.16_A7.html
fast/js/sputnik/Conformance/15_Native_Objects/15.8_Math/15.8.2/15.8.2.18_tan/S15.8.2.18_A7.htm
fast/js/sputnik/Unicode/Unicode_510/S7.6_A3.1.html

This bug will track these failures.
Comment 1 Martin Robinson 2010-08-05 12:12:08 PDT
Committed r64769: <http://trac.webkit.org/changeset/64769>
Comment 2 WebKit Review Bot 2010-08-05 12:36:53 PDT
http://trac.webkit.org/changeset/64769 might have broken GTK Linux 64-bit Debug
Comment 3 Martin Robinson 2010-08-05 12:44:23 PDT
Committed r64774: <http://trac.webkit.org/changeset/64774>
Comment 4 WebKit Review Bot 2010-08-05 13:15:08 PDT
http://trac.webkit.org/changeset/64774 might have broken GTK Linux 64-bit Debug
Comment 5 Martin Robinson 2010-08-05 13:40:47 PDT
Committed r64781: <http://trac.webkit.org/changeset/64781>
Comment 6 Zan Dobersek 2012-05-05 09:48:02 PDT
The following tests were found to be passing consistently after moving from using the Skipped list to using test_expectations.txt:
	sputnik/Conformance/15_Native_Objects/15.4_Array/15.4.4/15.4.4.12_Array_prototype_splice/S15.4.4.12_A2.1_T3.html

Their expectations were removed in r116122[1] (covered by bug #85591). Tests that are covered by this bug and are still failing are the following:
	sputnik/Conformance/15_Native_Objects/15.8_Math/15.8.2/15.8.2.16_sin/S15.8.2.16_A7.html
	sputnik/Conformance/15_Native_Objects/15.8_Math/15.8.2/15.8.2.18_tan/S15.8.2.18_A7.html
	sputnik/Unicode/Unicode_510/S7.6_A3.1.html

1: http://trac.webkit.org/changeset/116122
Comment 7 Thiago Marcos P. Santos 2012-05-07 02:05:34 PDT
(In reply to comment #6)
> The following tests were found to be passing consistently after moving from using the Skipped list to using test_expectations.txt:
>     sputnik/Conformance/15_Native_Objects/15.4_Array/15.4.4/15.4.4.12_Array_prototype_splice/S15.4.4.12_A2.1_T3.html
> 
> Their expectations were removed in r116122[1] (covered by bug #85591). Tests that are covered by this bug and are still failing are the following:
>     sputnik/Conformance/15_Native_Objects/15.8_Math/15.8.2/15.8.2.16_sin/S15.8.2.16_A7.html
>     sputnik/Conformance/15_Native_Objects/15.8_Math/15.8.2/15.8.2.18_tan/S15.8.2.18_A7.html
>     sputnik/Unicode/Unicode_510/S7.6_A3.1.html
> 
> 1: http://trac.webkit.org/changeset/116122

I have these two conformance tests failing on my machine (32-bits) for the EFL port, but it passes on the build bot (64-bits). IMO probably due to rounding.
Comment 8 Csaba Osztrogonác 2012-06-07 03:45:20 PDT
The following tests fail on Qt too, but only on 32 bit:
sputnik/Conformance/15_Native_Objects/15.8_Math/15.8.2/15.8.2.16_sin/S15.8.2.16_A7.html
sputnik/Conformance/15_Native_Objects/15.8_Math/15.8.2/15.8.2.18_tan/S15.8.2.18_A7.html

See https://bugs.webkit.org/show_bug.cgi?id=88519 for details.
Could you confirm if these tests fail on GTK in the same way?
Comment 9 Allan Sandfeld Jensen 2013-04-23 06:26:56 PDT

*** This bug has been marked as a duplicate of bug 88519 ***