Bug 43482 - Web Inspector: serialize database resources to InspectorValues
Summary: Web Inspector: serialize database resources to InspectorValues
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Yury Semikhatsky
URL:
Keywords:
: 41805 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-08-04 06:22 PDT by Yury Semikhatsky
Modified: 2010-08-11 09:46 PDT (History)
9 users (show)

See Also:


Attachments
Patch (13.81 KB, patch)
2010-08-04 06:33 PDT, Yury Semikhatsky
pfeldman: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yury Semikhatsky 2010-08-04 06:22:57 PDT
Web Inspector: serialize database resources to InspectorValues
Comment 1 Yury Semikhatsky 2010-08-04 06:33:02 PDT
Created attachment 63447 [details]
Patch
Comment 2 Pavel Feldman 2010-08-04 07:25:44 PDT
Comment on attachment 63447 [details]
Patch

WebCore/inspector/InspectorDatabaseResource.cpp:41
 +  int nextUnusedId = 1;
static ?
Comment 3 Yury Semikhatsky 2010-08-04 07:27:31 PDT
(In reply to comment #2)
> (From update of attachment 63447 [details])
> WebCore/inspector/InspectorDatabaseResource.cpp:41
>  +  int nextUnusedId = 1;
> static ?

Done.
Comment 4 Yury Semikhatsky 2010-08-04 07:43:51 PDT
Committing to http://svn.webkit.org/repository/webkit/trunk ...
	M	WebCore/ChangeLog
	M	WebCore/inspector/Inspector.idl
	M	WebCore/inspector/InspectorBackend.cpp
	M	WebCore/inspector/InspectorController.cpp
	M	WebCore/inspector/InspectorController.h
	M	WebCore/inspector/InspectorDatabaseResource.cpp
	M	WebCore/inspector/InspectorDatabaseResource.h
	M	WebCore/inspector/InspectorFrontend.cpp
	M	WebCore/inspector/InspectorFrontend.h
	M	WebCore/storage/Database.cpp
Committed r64650
Comment 5 Joseph Pecoraro 2010-08-11 09:46:53 PDT
*** Bug 41805 has been marked as a duplicate of this bug. ***