Bug 42669 - WebKitTestRunner needs layoutTestController.setJavaScriptCanAccessClipboard
Summary: WebKitTestRunner needs layoutTestController.setJavaScriptCanAccessClipboard
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2010-07-20 14:33 PDT by Sam Weinig
Modified: 2011-05-24 11:39 PDT (History)
6 users (show)

See Also:


Attachments
patch (10.73 KB, patch)
2011-05-20 13:44 PDT, qi
no flags Details | Formatted Diff | Diff
fix regression (3.00 KB, patch)
2011-05-24 09:07 PDT, qi
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sam Weinig 2010-07-20 14:33:59 PDT
WebKitTestRunner needs layoutTestController.setJavaScriptCanAccessClipboard
Comment 1 Sam Weinig 2010-07-20 15:33:33 PDT
<rdar://problem/8213875>
Comment 2 qi 2011-05-20 13:44:15 PDT
Created attachment 94265 [details]
patch
Comment 3 WebKit Commit Bot 2011-05-23 07:19:29 PDT
The commit-queue encountered the following flaky tests while processing attachment 94265 [details]:

http/tests/misc/favicon-loads-with-icon-loading-override.html bug 58412 (author: alice.liu@apple.com)
The commit-queue is continuing to process your patch.
Comment 4 WebKit Commit Bot 2011-05-23 07:20:45 PDT
Comment on attachment 94265 [details]
patch

Clearing flags on attachment: 94265

Committed r87072: <http://trac.webkit.org/changeset/87072>
Comment 5 WebKit Commit Bot 2011-05-23 07:20:50 PDT
All reviewed patches have been landed.  Closing bug.
Comment 6 Simon Fraser (smfr) 2011-05-23 10:28:37 PDT
This seems to have caused about 90 new test failures on the SnowLeopard WebKit2 bot. Please investigate.
Comment 7 qi 2011-05-23 10:51:58 PDT
I am investigating..
Comment 8 Chang Shu 2011-05-23 14:55:31 PDT
I was helping Qi a little bit...
I updated my webkit revision to r87071 (the one before Qi's commit) and still reproduced 4 failures under execCommand:
Testing 219 test cases.
editing/execCommand ...............
editing/execCommand/4128080-2.html -> failed
........................................................................
editing/execCommand/copy-without-selection.html -> failed
.............................................................................................
editing/execCommand/paste-1.html -> failed
.
editing/execCommand/paste-2.html -> failed
......................................
4.39s total testing time

Probably the regression happened earlier. But the buildbot seemed fine.
Comment 9 Chang Shu 2011-05-24 07:23:25 PDT
(In reply to comment #8)
> I was helping Qi a little bit...
> I updated my webkit revision to r87071 (the one before Qi's commit) and still reproduced 4 failures under execCommand:
> Testing 219 test cases.
> editing/execCommand ...............
> editing/execCommand/4128080-2.html -> failed
> ........................................................................
> editing/execCommand/copy-without-selection.html -> failed
> .............................................................................................
> editing/execCommand/paste-1.html -> failed
> .
> editing/execCommand/paste-2.html -> failed
> ......................................
> 4.39s total testing time
> 
> Probably the regression happened earlier. But the buildbot seemed fine.

Please ignore the above comments. It was run in a "su [user]" environment and somehow it didn't generate the correct results. By switching to right user, the problem was successfully reproduced and verified. Qi's working on a patch. Should be soon.
Comment 10 qi 2011-05-24 09:07:48 PDT
Created attachment 94623 [details]
fix regression

Fixes the regression issue caused by patch 94265. The patch didn't intialize the setting before the 
layouttest starting, it will make the test cases after editing/execCommand/clipboard-access.html failed.
Because that case changed the setting.
Comment 11 Adam Roben (:aroben) 2011-05-24 10:14:36 PDT
Comment on attachment 94623 [details]
fix regression

Marking cq+ as I don't believe Qi Zhang is a committer. (In the future, you should mark your patches cq? to indicate that you want them to be committed once they are reviewed.)
Comment 12 Adam Roben (:aroben) 2011-05-24 10:33:42 PDT
Reopening the bug so the commit-queue will see the patch.
Comment 13 WebKit Commit Bot 2011-05-24 11:39:16 PDT
Comment on attachment 94623 [details]
fix regression

Clearing flags on attachment: 94623

Committed r87175: <http://trac.webkit.org/changeset/87175>
Comment 14 WebKit Commit Bot 2011-05-24 11:39:22 PDT
All reviewed patches have been landed.  Closing bug.