Bug 41848 - [SVG] g color property should overwrite rect color property
Summary: [SVG] g color property should overwrite rect color property
Status: RESOLVED DUPLICATE of bug 38102
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL: http://dev.w3.org/SVG/profiles/1.1F2/...
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-08 05:48 PDT by Zoltan Herczeg
Modified: 2010-07-08 10:39 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zoltan Herczeg 2010-07-08 05:48:49 PDT
<g fill="currentColor" color="lime">
    <rect x="0" y="0" width="150" height="150" color="red"/>
</g>

This should draw a green (lime) box, not a red one (Firefox do this).

LayoutTests/svg/W3C-SVG-1.1 does not contain color-prop-05-t.svg, only its expected value. No idea why.

Without the color property, it works:

<g fill="currentColor" color="lime">
    <rect x="0" y="0" width="150" height="150"/>
</g>

Trying to fix this. Any suggestions are welcome.
Comment 1 Dirk Schulze 2010-07-08 10:39:30 PDT

*** This bug has been marked as a duplicate of bug 38102 ***