Bug 38102 - Wrong handling of currentColor on inherit
: Wrong handling of currentColor on inherit
Status: RESOLVED DUPLICATE of bug 54800
: WebKit
SVG
: 528+ (Nightly build)
: PC Mac OS X 10.5
: P2 Normal
Assigned To:
: http://dev.w3.org/SVG/profiles/1.1F2/...
:
:
:
  Show dependency treegraph
 
Reported: 2010-04-25 23:15 PST by
Modified: 2011-03-01 00:35 PST (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2010-04-25 23:15:47 PST
The SVG in the link has following example:

<g fill="currentColor" color="red">
    <rect x="120" y="60" width="150" height="150" color="blue"/>
</g>

Our current implementation inherits the 'fill' property of the <g> element: 'currentColor'. Our PaintServer see the value 'currentColor' for 'fill' on drawing the rect. It takes the value in 'color' of the rect, instead of the <g> element. This is not the expected behavior.
The relevant code is here: http://trac.webkit.org/browser/trunk/WebCore/rendering/RenderSVGResource.cpp#L97
The same issue for stroke.
------- Comment #1 From 2010-07-08 10:39:30 PST -------
*** Bug 41848 has been marked as a duplicate of this bug. ***
------- Comment #2 From 2011-03-01 00:35:21 PST -------

*** This bug has been marked as a duplicate of bug 54800 ***