Bug 41718 - Mac OS X media controls should have a way to adjust volume incrementally
Summary: Mac OS X media controls should have a way to adjust volume incrementally
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.6
: P2 Normal
Assignee: Eric Carlson
URL:
Keywords: InRadar
: 41980 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-07-06 15:16 PDT by Eric Carlson
Modified: 2010-07-12 14:49 PDT (History)
1 user (show)

See Also:


Attachments
proposed patch (33.15 KB, patch)
2010-07-06 16:15 PDT, Eric Carlson
mitz: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Carlson 2010-07-06 15:16:55 PDT
Media controls should have a slider to control audio volume, not just a button that toggles mute.
Comment 1 Eric Carlson 2010-07-06 15:17:16 PDT
<rdar://5679472>
Comment 2 Eric Carlson 2010-07-06 16:15:16 PDT
Created attachment 60661 [details]
proposed patch
Comment 3 mitz 2010-07-07 14:22:17 PDT
Comment on attachment 60661 [details]
proposed patch

> +          (WebCore::MediaControlMuteButtonElement::MediaControlMuteButtonElement): Add ButtonLocation 
> +          parameter both mute buttons can be created.

Missing a word there?


> +audio::-webkit-media-controls-volume-slider-container, video::-webkit-media-controls-volume-slider-container {
> +    -webkit-appearance: media-volume-slider-container;
> +    position: absolute;
> +
> +    width: 22px;
> +    height: 114px;
> +}

I wonder if this can specify one of top/bottom and one of left/right.

> +IntPoint RenderThemeMac::volumeSliderOffsetFromMuteButton(Node* muteButton, const IntSize& size) const
> +{
> +    static const int xOffset = -4;
> +    static const int yOffset = 5;
> +
> +    int y = muteButton->renderBox()->offsetHeight() + yOffset - size.height();
> +    FloatPoint absPoint = muteButton->renderer()->localToAbsolute(FloatPoint(muteButton->renderBox()->offsetLeft(), y), true, true);
> +    if (absPoint.y() < 0)
> +        y = muteButton->renderBox()->height();
> +    return IntPoint(xOffset, y);
> +}

I think I know what this does but a comment wouldn’t hurt.

r=me!
Comment 4 Eric Carlson 2010-07-08 13:04:37 PDT
http://trac.webkit.org/changeset/62821
Comment 5 Eric Carlson 2010-07-12 14:49:19 PDT
*** Bug 41980 has been marked as a duplicate of this bug. ***