Bug 41030 - CSS Outline doesn't render for Table elements
Summary: CSS Outline doesn't render for Table elements
Status: RESOLVED DUPLICATE of bug 55474
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tables (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords: HasReduction
Depends on:
Blocks:
 
Reported: 2010-06-22 19:30 PDT by Tom Robinson
Modified: 2011-03-29 09:43 PDT (History)
4 users (show)

See Also:


Attachments
Firefox vs Chrome rendering of table { outline: ... } (40.43 KB, image/png)
2010-06-22 19:30 PDT, Tom Robinson
no flags Details
Reduction (265 bytes, text/html)
2011-02-27 16:23 PST, Daniel Bates
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Robinson 2010-06-22 19:30:51 PDT
Created attachment 59464 [details]
Firefox vs Chrome rendering of table { outline: ... }

Chrome, Safari and Dreamweaver CS5 Live View won't render outlines around Table elements.

Sample code:
<!DOCTYPE html>
<html>
<head>
<style>
table, span, div { margin: 20px; outline: 5px dotted lime; border: 1px solid black }
</style>
</head>
<body>
<table><tr><td>this is a table</td></tr></table>
<div>this is a div</div>
<span>this is a span</span>
</body>
</html>

Works as expected in Firefox, Opera, IE8, IE9.
See attached image for Firefox vs Chrome.
Comment 1 Daniel Bates 2011-02-27 16:19:35 PST
Confirmed that the CSS outline property is not honored for <table> using Mac nightly r79746.

Moreover, the outline property is not honored for table rows and row-groups.
Comment 2 Daniel Bates 2011-02-27 16:23:19 PST
Created attachment 84002 [details]
Reduction

For convenience, the sample code posted in comment 0 as an attachment.
Comment 3 kyounga 2011-03-29 01:23:17 PDT
This is a duplicate issue of #55474 and it is fixed already.
Comment 4 Daniel Bates 2011-03-29 09:43:17 PDT

*** This bug has been marked as a duplicate of bug 55474 ***