Bug 40548 - Improved editor options for prepare-ChangeLog and commit-log-editor
Summary: Improved editor options for prepare-ChangeLog and commit-log-editor
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other OS X 10.5
: P2 Normal
Assignee: Darin Adler
URL:
Keywords:
: 40756 (view as bug list)
Depends on: 43865
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-13 12:17 PDT by Darin Adler
Modified: 2010-08-14 13:32 PDT (History)
2 users (show)

See Also:


Attachments
Patch (4.29 KB, patch)
2010-06-13 12:18 PDT, Darin Adler
no flags Details | Formatted Diff | Diff
Patch for landing (4.44 KB, patch)
2010-08-10 22:31 PDT, Adam Barth
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Darin Adler 2010-06-13 12:17:11 PDT
Improved editor options for prepare-ChangeLog and commit-log-editor
Comment 1 Darin Adler 2010-06-13 12:18:48 PDT
Created attachment 58600 [details]
Patch
Comment 2 Darin Adler 2010-06-16 23:04:45 PDT
*** Bug 40756 has been marked as a duplicate of this bug. ***
Comment 3 Kenneth Rohde Christiansen 2010-06-28 07:27:24 PDT
Comment on attachment 58600 [details]
Patch

WebKitTools/Scripts/commit-log-editor:92
 +  $editor = "/usr/bin/vi" if !$editor;
Should this really be hardcoded? why not just use vi from your PATH?
Comment 4 Darin Adler 2010-06-28 15:37:19 PDT
(In reply to comment #3)
> (From update of attachment 58600 [details])
> WebKitTools/Scripts/commit-log-editor:92
>  +  $editor = "/usr/bin/vi" if !$editor;
> Should this really be hardcoded? why not just use vi from your PATH?

Generally speaking we don't rely on PATH for the tools. It’s not something I feel passionate about. It’s been like this for about 8 years and I wasn’t looking to change it.
Comment 5 John Sullivan 2010-07-14 16:31:36 PDT
Comment on attachment 58600 [details]
Patch

Poor li'l patch, wasting away for so long!
Comment 6 Joseph Pecoraro 2010-07-14 16:50:10 PDT
Comment on attachment 58600 [details]
Patch

> +        values like "xed --launch --wait" work propertly.

Typo in the ChangeLog could be fixed: "propertly" => "properly"
Comment 7 Adam Barth 2010-08-10 22:31:11 PDT
Created attachment 64071 [details]
Patch for landing
Comment 8 WebKit Commit Bot 2010-08-11 05:54:32 PDT
Comment on attachment 64071 [details]
Patch for landing

Clearing flags on attachment: 64071

Committed r65148: <http://trac.webkit.org/changeset/65148>
Comment 9 WebKit Commit Bot 2010-08-11 05:54:38 PDT
All reviewed patches have been landed.  Closing bug.
Comment 10 Daniel Bates 2010-08-14 13:32:11 PDT
(In reply to comment #9)
> All reviewed patches have been landed.  Closing bug.

For historical preservation, this change caused some Perl warnings. These warnings were resolved in Bug #43856.