Bug 40505 - Position:relative; + Flash 10.1 element redraw and text aliasing bug
Summary: Position:relative; + Flash 10.1 element redraw and text aliasing bug
Status: RESOLVED DUPLICATE of bug 23364
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P2 Normal
Assignee: Nobody
URL: http://www.uberfoto.com/flash_problem...
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-11 16:14 PDT by Josh
Modified: 2010-06-13 11:21 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Josh 2010-06-11 16:14:47 PDT
There are some problems with the latest webkit build after installing the latest Flash 10.1 update. I'm not yet smart enough to determine whether this is strictly related to a problem with Flash 10.1 or a bug in the newest Webkit (or both combined).

I have confirmed the bug does NOT show in Safari 4, Firefox 3.6, Chrome 5.0.375.70, & IE7. Safari 5 and WebKit 528+ seem to be the only browsers that show the problem. All browsers tested in OSX 10.6.3


The problem occurs with relative position elements inside of relative positioned elements. Also, inside these relative elements inside relative elements, the font has anti aliasing problems once the YouTube clip loads.

There are two bugs that I explain on the page. Here is a quick description as well:

1. Watch the text inside the box change after the video loads into the page.
2. Click the red button in the top right corner and then scroll down. The nav should change to a fixed position and stay at the top of the browser (albeit, left dropdown menus only. The global nav will hide).

The page is a snippet I've taken from a working beta from a site I am developing. Please forgive some of the missing images, etc. I put it together quickly and wanted some functionality still there so you could see what happens when you play around with the page. For example: the sticky nav will appear if another animation occurs, effectively redrawing the nav again. After you click the button and scroll down the page, try moving your mouse to the area where the nav dropdown menus WOULD be. The browser will redraw the navbar and the menu will work but then once you scroll again, it's broken.



This is my first time submitting a bug here. If I am missing anything or whatever, let me know. Happy to help.
Comment 1 Simon Fraser (smfr) 2010-06-13 09:45:21 PDT
This is a known issue, covered by bug 23364.

*** This bug has been marked as a duplicate of bug 23364 ***
Comment 2 Josh 2010-06-13 10:34:09 PDT
@Simon, is this a single bug or two bugs. I can see the relevance with font smoothing to the mentioned bug report but I'm not sure it's also causing the redraw problems for block elements.
Comment 3 Simon Fraser (smfr) 2010-06-13 11:21:07 PDT
The flashing/redraw is also a known issue, tracked internally as <rdar://problem/6474145>. I filed bug 40547 avoid this redraw issue in cases like yours.