Bug 40421 - REGRESSION: GMail becomes blank after closing other tabs
Summary: REGRESSION: GMail becomes blank after closing other tabs
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P1 Normal
Assignee: Simon Fraser (smfr)
URL:
Keywords: InRadar, Regression
: 41738 41881 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-06-10 05:33 PDT by Ismail Donmez
Modified: 2010-07-09 12:49 PDT (History)
3 users (show)

See Also:


Attachments
Patch (6.34 KB, patch)
2010-07-06 22:45 PDT, Simon Fraser (smfr)
mitz: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ismail Donmez 2010-06-10 05:33:58 PDT
How to reproduce;

- Open GMail in one tab
- Open another tab and visit your favourite news site
- Open another tabs and visit just another site
- Close two tabs

Expected results:

- GMai is shown as usual

What happens instead:

- GMail tab is blank

Note 1: Safari 4/5 does not have this problem, only WebKit
Note 2: Disabling Flash plugin fixes the issue
Comment 1 Alexey Proskuryakov 2010-06-10 11:16:10 PDT
I cannot reproduce this with r60936 on Mac OS X 10.5.8 and Flash 10.0 r42 installed.
Comment 2 Ismail Donmez 2010-06-10 11:18:14 PDT
(In reply to comment #1)
> I cannot reproduce this with r60936 on Mac OS X 10.5.8 and Flash 10.0 r42 installed.

Would you mind trying with Flash 10.1 rc7? I am on OSX 10.6.3 fwiw.
Comment 3 Ismail Donmez 2010-06-10 14:11:28 PDT
Looks like Adobe just released Flash Plugin 10.1 as stable and bug is reproducible with it.
Comment 4 Ismail Donmez 2010-06-10 14:34:30 PDT
Problem doesn't seem to reproducible with Flash plugin 10.0 r45, so the problem lies in the 10.1 update.
Comment 5 Simon Fraser (smfr) 2010-06-10 15:13:55 PDT
<rdar://problem/8081382>
Comment 6 Alexey Proskuryakov 2010-06-11 14:33:45 PDT
I could reproduce this on Mac OS X 10.6 with nightly r60968 and Flash 10.1. I could not reproduce under the same configuration with accelerated compositing disabled.

Doesn't seem to happen with shipping Safari/WebKit 5 indeed.
Comment 7 Simon Fraser (smfr) 2010-07-06 22:35:52 PDT
*** Bug 41738 has been marked as a duplicate of this bug. ***
Comment 8 Simon Fraser (smfr) 2010-07-06 22:45:32 PDT
Created attachment 60683 [details]
Patch
Comment 9 mitz 2010-07-06 22:56:20 PDT
Comment on attachment 60683 [details]
Patch

WebCore/ChangeLog:16
 +          are suspended (indicating that we'reinside recalcStyle()).
Typo: we'reinside

I would have added a public setNeedsStyleRecalcSoon() method to HTMLFrameOwnerElement and not exposed ContainerNode::queuePostAttachCallBack().

r=me
Comment 10 Simon Fraser (smfr) 2010-07-07 12:28:44 PDT
http://trac.webkit.org/changeset/62687
Comment 11 Ismail Donmez 2010-07-09 05:00:55 PDT
The original bug is fixed but there is still a one time flicker when switching to GMail tab, which is a regression compared to Safari 5.
Comment 12 Simon Fraser (smfr) 2010-07-09 08:46:39 PDT
The flicker is a tiled layer issue. I'm working on fixing that via bug 34009.
Comment 13 Simon Fraser (smfr) 2010-07-09 12:49:03 PDT
*** Bug 41881 has been marked as a duplicate of this bug. ***