Bug 39472 - [GStreamer] multiple video sink support
Summary: [GStreamer] multiple video sink support
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Nobody
Depends on: 39474 39740
Blocks: 39202
  Show dependency treegraph
Reported: 2010-05-20 23:27 PDT by Philippe Normand
Modified: 2010-06-25 00:07 PDT (History)
2 users (show)

See Also:

proposed patch (7.11 KB, patch)
2010-05-28 10:01 PDT, Philippe Normand
gustavo: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Normand 2010-05-20 23:27:02 PDT
For video fullscreen support it would be nice if the player could do the rendering using autovideosink. This requires the current playbin2 video-sink to be a bin internally rendering to the webkit videosink and, when needed for fullscreen, autovideosink.

For this to work on application-side, gst XOverlay support is also needed in GStreamerGWorld, otherwise autovideosink (on gtk port) will internally create and show an X11 window.
Comment 1 Philippe Normand 2010-05-28 10:01:22 PDT
Created attachment 57337 [details]
proposed patch
Comment 2 Philippe Normand 2010-06-01 10:37:24 PDT
Sebastian, can you have a look at the patch when you get some time please? :)
Comment 3 Sebastian Dröge (slomo) 2010-06-03 01:11:35 PDT
Looks good, yes
Comment 4 Philippe Normand 2010-06-22 00:57:30 PDT
Gustavo, would you have time to take a look? Bug 39474 too if possible. Sebastian  did one pass on the patches already, some time ago :)
Comment 5 Gustavo Noronha (kov) 2010-06-24 06:49:19 PDT
Comment on attachment 57337 [details]
proposed patch

It looks very good to me. The only improvement I suggest is not creating member variables for the queue and the tee. They are completely useless - you are not even using them when enabling fullscreen, so just make them variables scoped to the createGSTPlayBin function, please, unless you have a good reason to keep them. I would prefer having more descriptive names for the queue and tee elements, too "t" does the job, but we can do better, I guess? =)
Comment 6 Philippe Normand 2010-06-25 00:07:08 PDT
Landed as http://trac.webkit.org/changeset/61834 with the suggested fixes. Thanks for the review :)