Bug 39380 - Slow vertical scrolling when text is selected in nested divs
Summary: Slow vertical scrolling when text is selected in nested divs
Status: RESOLVED DUPLICATE of bug 100413
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Mac (Intel) OS X 10.6
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-19 14:26 PDT by Nate Whetsell
Modified: 2012-11-16 18:30 PST (History)
4 users (show)

See Also:


Attachments
100 div pairs in a div floated left (17.82 KB, text/html)
2010-05-19 14:26 PDT, Nate Whetsell
no flags Details
100 divs in a plain div (not floated) (17.83 KB, text/html)
2010-05-19 14:27 PDT, Nate Whetsell
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nate Whetsell 2010-05-19 14:26:35 PDT
Created attachment 56520 [details]
100 div pairs in a div floated left

On OS X 10.6, selecting all the text in a webpage consisting of several (100 in the attached test documents) of these:

<div>
  <div class="float-left">
      [some text]
  </div>
</div>

produces sluggish vertical scrolling. (The "float-left" class is used to define a style for floating a div left: div.float-left{float:left;}).

If these snippets are enclosed in a div that is itself floated left (or right), both upward and downward scrolling are sluggish. If the snippets are enclosed in a div without a float style (or no div at all), only upward scrolling is sluggish. If no text is selected, scrolling is fast and smooth.

The sluggishness only occurs when text is inside a pair of divs; removing the outer div results in fast scrolling. Also, the inner div must be the one that's floated. If the outer div is floated, vertical scrolling while text is selected is fast.

Sluggish scrolling also occurs in Google Chrome. Firefox scrolls smoothly.
Comment 1 Nate Whetsell 2010-05-19 14:27:28 PDT
Created attachment 56521 [details]
100 divs in a plain div (not floated)
Comment 2 Alexey Proskuryakov 2011-07-06 08:52:36 PDT
Still happens with nightly r89812. Busy in RenderBlock::selectionGaps().
Comment 3 Nate Whetsell 2012-11-16 18:30:23 PST
This was fixed in <http://trac.webkit.org/r132545>.

*** This bug has been marked as a duplicate of bug 100413 ***