Bug 39295 - Crash (preceded by assertion) in WKCACFLayerRenderer::setNeedsDisplay when computer wakes from sleep on particular page
: Crash (preceded by assertion) in WKCACFLayerRenderer::setNeedsDisplay when co...
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering
: 528+ (Nightly build)
: PC Windows XP
: P2 Normal
Assigned To: Nobody
: InRadar, PlatformOnly
Depends on:
Blocks: 39297
  Show dependency treegraph
 
Reported: 2010-05-18 09:01 PDT by Adam Roben (:aroben)
Modified: 2010-05-18 12:36 PDT (History)
5 users (show)

See Also:


Attachments
testcase (just an auto-reloading version of poster-circle.html) (5.51 KB, text/html)
2010-05-18 09:01 PDT, Adam Roben (:aroben)
no flags Details
Fix a crash when a page that uses accelerated compositing loads soon after the computer wakes from sleep (13.06 KB, patch)
2010-05-18 09:50 PDT, Adam Roben (:aroben)
sullivan: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Roben (:aroben) 2010-05-18 09:01:37 PDT
Created attachment 56382 [details]
testcase (just an auto-reloading version of poster-circle.html)

To reproduce:

1. Load the attached testcase
2. Put your computer to sleep
3. Wake your computer up

You'll crash inside WKCACFLayerRenderer::setNeedsDisplay due to m_rootLayer being null. Here's a partial backtrace:

WKCACFLayerRenderer::setNeedsDisplay(void)+0xf
WebView::repaint(class WebCore::IntRect * windowRect = 0x7fb4ad20, bool contentChanged = true, bool immediate = false, bool repaintContentOnly = false)+0x29
WebChromeClient::invalidateContentsAndWindow(class WebCore::IntRect * windowRect = 0x68407b51, bool immediate = false)+0x16
WebCore::ScrollView::repaintContentRectangle(class WebCore::IntRect * rect = 0x7c2ff300, bool now = false)+0x9b
WebCore::FrameView::doDeferredRepaints(void)+0x81
WebCore::FrameView::endDeferredRepaints(void)+0x78
WebCore::FrameView::layout(bool allowSubtree = true)+0x5a2
WebCore::Timer<WebCore::MediaPlayerPrivate>::fired(void)+0xe
WebCore::ThreadTimers::sharedTimerFiredInternal(void)+0xef
WebCore::ThreadTimers::sharedTimerFired(void)+0xe
Comment 1 Adam Roben (:aroben) 2010-05-18 09:01:58 PDT
<rdar://problem/7971319>
Comment 2 Adam Roben (:aroben) 2010-05-18 09:50:53 PDT
Created attachment 56384 [details]
Fix a crash when a page that uses accelerated compositing loads soon after the computer wakes from sleep
Comment 3 Adam Roben (:aroben) 2010-05-18 12:36:15 PDT
Committed r59682: <http://trac.webkit.org/changeset/59682>