Bug 38252 - webkitpy: run_webkit_tests.py hangs: pthread_cond_wait: Invalid argument
: webkitpy: run_webkit_tests.py hangs: pthread_cond_wait: Invalid argument
Status: RESOLVED DUPLICATE of bug 38300
: WebKit
Tools / Tests
: 528+ (Nightly build)
: All Mac OS X 10.5
: P2 Normal
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2010-04-28 03:02 PST by
Modified: 2010-04-28 21:04 PST (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2010-04-28 03:02:53 PST
run_webkit_tests.py hangs on mac.
http://build.chromium.org/buildbot/waterfall.fyi/builders/Webkit%20Mac%20(webkit.org)/builds/18967/steps/webkit_tests/logs/stdio

python /b/slave/webkit-rel-mac-webkit-org/build/src/webkit/tools/layout_tests/run_webkit_tests.py --noshow-results --verbose --full-results-html --clobber-old-results --results-directory ../../../layout-test-results --target Release --builder-name "Webkit Mac (webkit.org)" --build-number 18967 --build-name webkit-rel-mac-webkit-org ""
100428 02:35:28 metered_stream.py:101  INFO Clobbering old results in /b/slave/webkit-rel-mac-webkit-org/build/src/webkit/Release/../../../layout-test-results
100428 02:35:28 base.py:329  DEBUG Using WebKit root: /b/slave/webkit-rel-mac-webkit-org/build/src/third_party/WebKit/
100428 02:35:30 run_webkit_tests.py:1582 INFO Running 2 TestShells in parallel
100428 02:35:30 run_webkit_tests.py:1592 INFO Regular timeout: 6000, slow test timeout: 30000
...
100428 02:40:35 dump_render_tree_thread.py:349  DEBUG Thread-1 fast/table/cell-width-auto.html passed
pthread_cond_wait: Invalid argument
pthread_cond_wait: Invalid argument
pthread_cond_wait: Invalid argument
pthread_cond_wait: Invalid argument
100428 02:40:35 dump_render_tree_thread.py:349  DEBUG Thread-1 fast/table/cellindex.html passed
100428 02:40:35 dump_render_tree_thread.py:349  DEBUG Thread-1 fast/table/click-near-anonymous-table.html passed
100428 02:40:35 dump_render_tree_thread.py:349  DEBUG Thread-1 fast/table/col-width-span-expand.html passed
100428 02:40:35 dump_render_tree_thread.py:349  DEBUG Thread-1 fast/table/colgroup-preceded-by-caption.html passed
100428 02:40:35 dump_render_tree_thread.py:346  DEBUG Thread-2 fast/repaint/overflow-scroll-delete.html failed:
  Image mismatch
pthread_cond_wait: Invalid argument
100428 02:40:35 dump_render_tree_thread.py:349  DEBUG Thread-1 fast/table/colgroup-relative.html passed
100428 02:40:35 dump_render_tree_thread.py:349  DEBUG Thread-1 fast/table/colgroup-spanning-groups-rules.html passed
100428 02:40:35 dump_render_tree_thread.py:349  DEBUG Thread-1 fast/table/colspanMinWidth.html passed
100428 02:40:35 dump_render_tree_thread.py:349  DEBUG Thread-1 fast/table/destroy-cell-with-selection-crash.html passed

command timed out: 600 seconds without output, killing pid 76931
process killed by signal 9
program finished with exit code -1
elapsedTime=910.183127
------- Comment #1 From 2010-04-28 11:53:27 PST -------
I have no idea.

I've just about given up trying to fix Chromium's pile of untested brittle python code.

Maybe this is some symptom of http://bugs.python.org/issue2320 again?
------- Comment #2 From 2010-04-28 12:43:29 PST -------
Does its hang every time?  Have we seen this more than once?

http://developer.apple.com/mac/library/documentation/Darwin/Reference/ManPages/man3/pthread_cond_wait.3.html

Would suggest that something down in python land is wrong or corrupted.
------- Comment #3 From 2010-04-28 21:04:54 PST -------
Sorry, I forgot about this bug again and filed a new one.

This is clearly a bug in python itself.  Not sure how we're triggering it yet.  See bug 38300.

*** This bug has been marked as a duplicate of bug 38300 ***